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About This Guide
This guide describes the Dell™ Active System Manager web user interface. This guide provides 
information needed to maintain and support the hardware and software environment of the Active System 
Manager product, and describes the architecture and operations of the Active System Manager product. 

This preface contains the following topics:

• Intended Audience

• Organization

• Conventions

• Active System Manager Documentation Lineup

Intended Audience

This guide is intended for system and network administrators who are responsible for managing an 
environment with the Active System Manager software and non-administrator users who use the Active 
System Manager web interface.

All users should be familiar with the following concepts to use the Active System Manager product. 

• Basic principles and use of the Active System Manager product

• Inventory and change management

• UNIX operating system and common UNIX commands

• Physical environment (layout, connectivity, inventory)

• Oracle database administration

• Licensing concepts

• Test management and automation, as well as integration methodologies and framework

• Web applications and XML language

In addition to these concepts, Dell also recommends reading the Active System Manager User Guide in 
conjunction with this guide.
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Organization
Organization

Table 1 defines how this guide is organized.Specific administrator and non-administrator roles are 
identified for each chapter.

Table 1 Organization of This Guide 

Chapter Description Admin Non-Admin

Chapter 1, “Active System 
Manager Product Overview”

Describes the overall Dell Automation Suite, including the key benefits, all 
high-level functions, concepts, and features.

X X

Chapter 2, “Accessing the 
Active System Manager Web 
Portal”

Provides login information for the Active System Manager web interface. X X

Chapter 3, “Home” Describes the features and functionality available on the Home sub-menu. X X

Chapter 4, “Sessions” Defines how to manage environment sessions and describes related 
features and functionality.

X X

Chapter 5, “Templates” Describes the Templates sub-menu and its related features and 
functionality.

X X

Chapter 6, “Resources” Describes the Resources sub-menu and its related features and 
functionality.

X

Chapter 7, “Reports” Lists and describes the reporting feature of the Active System Manager 
software to generate reports detailing your environment sessions, 
summarized equipment inventory information, and detailed equipment 
inventory information.

X X

Chapter 8, “Security” Describes the Security sub-menu and its related features and functionality. X

Chapter 9, “Settings” Describes the Settings sub-menu and its related features and functionality. X
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Conventions
Conventions

This guide uses special conventions for the following elements:

• Notes, Cautions, and Warnings

• Syntax Conventions

• Administrator Role Icon

Notes, Cautions, and Warnings

Caution Indicates either potential damage to hardware or loss of data and tells you how to avoid the 
problem.

Warning Indicates a potential for property damage, personal injury, or death.

Note Indicates information that emphasizes or supplements the main text. A note supplies information 
that may apply only in special cases; for example, memory limitations or equipment configurations.

Syntax Conventions
Table 2 describes the text format and character conventions used in this guide.

Table 2 Syntax Conventions 

Text Format Convention Example

Bold Indicates toolbar buttons, menu selections, field 
names, or items that you click, press, or type. 

Click Add or select the SaveAs option.

Courier Indicates console output, path names, source 
code, and filenames.

C:\dell\ActiveSystemManagerGaleForce

Italic Indicates path names for which you must supply 
a value.
Indicates a referenced name, especially in 
glossary, where See references occur.
Indicates external documentation references.

Drag the interfaces into the WP group, or select Bind > WP 
name, or right-click the interface, and select Bind > WP 
name.
This feature is called property-based scheduling.
For more information, see the Active System Manager 
Release Notes.

Right angle bracket > Indicates a procedural series of submenus that 
open from a primary menu.

Click File > New > Worksheet.

Separator characters 
(@, _)

Separates a subscriber name or administrator 
name and a domain name or domain alias, or 
console output that requires text to include a 
space.

support@dell.com
The format for any image file is:
/osimage/username_that_imported_the_image/
imagename
About This Guide 7



Active System Manager Documentation Lineup
Administrator Role Icon
An administrator’s role is the highest level of permission that is granted to a computer user. This level of 
permission normally allows the user to install software, and change configuration settings.

For administrator only tasks, the administrator icon is used to identify that sole role. For non-administrator 
tasks, no icon is used. 

The Active System Manager administrator can perform the following functions:

• Create, modify, delete, and save templates of all users

• Configure system-wide session notifications and reminders

• Cancel, modify, delete, and save (snapshot) sessions

• Start and stop ASAP Rescheduling and other scheduling properties

Active System Manager Documentation Lineup

The current lineup of the Active System Manager product guide documentation for this release includes the 
following:

• Active System Manager User Guide—Describes the installation, operation, and usage of the Active 
System Manager Control Center client software. This guide provides information for end users and 
system administrator roles. 

• Active System Manager Online Help—Provides quick online access to the GUI Help and reference 
material, including the Active System Manager User Guide.

• Active System Manager Solution Guide for AS800—Describes the Active System Manager installation 
and deployment in the context of managing a Dell AS800 converged infrastructure solution.

• Active System Manager Release Notes—Provides a summary of the latest Active System Manager 
features, software changes, and system requirements, as well as the customer-facing known issues and 
resolved issues unique to each particular release.
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Active System Manager Product Overview
C h a p t e r  1
Active System Manager 
Product Overview
The Dell™ Active System Manager solution sits at the center of the Active System, and simplifies 
infrastructure configuration, collapses management tools, and drives automation and consistency. Through 
capabilities such as template-based provisioning, automated configuration and infrastructure life cycle 
management, the Active System Manager product enables IT to respond rapidly to business needs, 
maximize data center efficiency and strengthen quality of IT service delivery. 

Rapidly Respond to Business Needs 

The Active System Manager streamlines the complex and tedious task of infrastructure configuration. It 
enables IT to quickly on-board new infrastructure or rapidly reconfigure existing infrastructure. This 
significantly speeds time to production for new workloads or scaling of resources for existing workloads. 

This dramatic simplification in infrastructure configuration is achieved through automated discovery and 
inventory of bladed infrastructure, and centralization of infrastructure requirements in the form of 
templates. Once defined, templates within the Active System Manager can be repeatedly and consistently 
utilized to streamline workload deployment. 

Maximize Data Center Efficiency 

The Active System Manager empowers IT to achieve higher efficiencies through automation. By reducing, 
and in most cases eliminating manual steps, IT organizations can free up time to focus on initiatives that 
make a deeper impact on their organization and the business. 

While automation is a cornerstone of efficiency, many IT organizations today are also encumbered with 
multiple management consoles. The Active System Manager offers an intuitive, single point of control for 
key infrastructure configuration and management functions, enabling IT to minimize the number of 
consoles that are needed on a regular basis.

Strengthen Quality of IT Service Delivery 

Assuring service levels is always tricky; there are just too many variables that can impact service delivery. 
The Active System Manager addresses key factors that impact service levels, namely infrastructure 
configuration errors, incorrect problem troubleshooting and slow recovery from failures. 

The Active System Manager dramatically improves accuracy of infrastructure configuration by reducing 
manual touch points. If an unexpected error (such as a hardware fault) occurs or if business needs change, 
Active System Manager enables rapid and smooth workload migration, thereby improving recovery time. 

The Active System Manager also enables better infrastructure management decisions through user 
workloads and multi-level graphical views of infrastructure topologies. These capabilities enable an IT 
administrator to make better decisions up front and troubleshoot problems more effectively if they do occur, 
thereby minimizing unexpected downtime and improving recovery time.
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The Active System Manager product enhances the functionality of the Active System Manager by 
providing a more complete, end-to-end automation solution for both physical and virtual resources. The 
software enables a cloud like environment, and support pre-built provisioning templates and custom 
orchestrated workflows for a wide range of physical or virtual environments.

It offers the ability to: 

• Enhance the discovery and inventory of all components across multiple Active Systems.

• Create and manage capacity of resources and resource pools spanning multiple systems.

• Simplify adding new or existing infrastructure resources to the resource pools, with an extensive 
plug-and-play capability.

• Automate template-based provisioning and de-provisioning of multi-VM workloads (along with the 
required virtual networking and storage capabilities).

• Create and publish infrastructure templates.

• Associate multiple custom and flexible orchestrations for end-to-end life cycle management of 
workloads.

• Schedule, allocate, and ensure capacity for complex workloads at current or future times.

• Provide an Infrastructure as a Service (IaaS) portal for the IT administrator.

Table 1-1 Features and Benefits

Features Function Benefit

Inventory • Discovery and management of 
resources.

• Accelerates the manual and often 
laborious process of discovering and 
providing an inventory of new 
infrastructure.

Automation • Fully automated provisioning of 
end-to-end physical and virtual 
infrastructure, using a visual 
drag-and-drop authoring interface.

• Ensures a solid, high quality foundation 
for new workloads.

• Speeds up the deployment of new 
infrastructure.

Orchestration • Pre-built and custom-orchestrated 
provisioning workflows for fine-grained 
control of provisioning methods and 
policies, for setup, run-time, and 
tear-down.

• Pre-built workflows offer straight 
forward guidance based on best 
practices.

• Customization offers flexibility required 
for unique enterprise needs.

Scheduling and 
Allocation

• Advanced scheduling and reservation 
system for highly efficient allocation of 
resources and guaranteed resource 
commitments.

• Ensure business, and in turn their 
applications, get prioritized access to 
the resources they demand, and pay 
for.

• Drive efficiency in the datacenter by 
minimizing oversubscription of costly 
resources.

Enterprise Integration • LDAP/AD capabilities and role-based 
access control for enterprise 
management.

• Simple and efficient integration with 
enterprise resources.

Capacity Optimization • Unified management of both physical 
and virtual resources, along with 
capacity-based scheduling capabilities.

• Provides optimized resource allocation 
and ensures high asset utilization.
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Active System Manager Architecture
Active System Manager Architecture

At the heart of the Active System Manager software’s architectural and functional strengths is the Active 
System Manager Server, which provides support for inventory and resource allocation; template design and 
visualization; resource scheduling and reservation, together with capacity allocation and management, and 
the highly flexible automation workflow engine that enables the cross-domain, end-to-end provisioning for 
which the Active System Manager is known.

The Active System Manager Control Center client is used by administrators and architects for managing 
resources and resource pools, and for designing and modeling infrastructure and service templates that can 
be published to the end-user communities. Such templates represent pre-built designs for workloads that 
can range from individual physical or virtual resources, such as servers or virtual machines, to full, 
top-to-bottom software stacks, to complete end-to-end multi-tier architectures.

The Active System Manager web portal is a self-service, catalog-like interface through which users can 
browse, select, schedule, and have resources automatically provisioned based on the wide range of 
predefined templates. The web portal includes support for custom branding to an organization’s own look 
and feel, and is designed for one-click access to enable the levels of efficiency and scalability needed for 
already-existing global deployments.

The Active System Manager Resource Adapter Framework (RAF) is what enables the Active System 
Manager server to control, automate, and orchestrate resource pools that encompass a wide range of 
physical and resource types, through the plug-in Resource Adapters. 

The Resource Adapter Framework is an extensible and modular layer in the Active System Manager 
architecture that supports adapters or drivers to a wide range of products and technologies, including 
servers and computing resources; switches, routers, and networking equipment; storage arrays and storage 
area networking products; firewall, security, and access equipment; hypervisors and virtualization 
management software; file servers and version control repositories; public Cloud Application 
Programming Interfaces (APIs); and element managers and other software applications.
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Active System Manager Architecture
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Accessing the Active System Manager Web Portal
C h a p t e r  2
Accessing the Active System Manager 
Web Portal
Before logging on to the Active System Manager portal, Dell™ recommends to review and follow these 
pre-requisite guidelines/notes: 

Note Refer to the Active System Manager User Guide for information on connecting to the Active 
System Manager server. 

After connecting to the Active System Manager server, you must log on through an 
authentication page.

Note You must have a valid Active System Manager license to log on to the Active System 
Manager web portal.

If you are an Active System Manager registered user, perform the following steps to log onto the Active 
System Manager web portal.

Note If you are a new user, your administrator must register your credentials to grant you access.

1. On your Internet browser, type in http://<your server name>:<Active System Manager port number>.

The Active System Manager product page displays.

After a few seconds, the Login page displays; see Figure 2-1.

Note The portal look and feel, title, subtitle, and the RSS feed can be customized. 

Refer to the Active System Manager Installation and Maintenance Guide for information on 
modifying the aforementioned settings. 
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Figure 2-1 Active System Manager Web Interface Logon Page

2. Enter your access credentials as follows:

a. Click the Username field and enter your username.

b. Click the Password field and enter your password.
Note The administrator can use the admin/admin factory-supplied default credentials. Using 

these default credentials, the super administrator can create multiple administrators.

c. Click OK.

By default, the Active System Manager Home> Announcements page displays; see Figure 2-2 for 
an example of an administrator logon.
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Figure 2-2 Active System Manager Home> Announcements Page (Administrator)

The Active System Manager web portal menu bar includes the following menus (these menus are described 
in the chapters indicated by each menu name):

• Home (see Chapter 3, “Home”)

• Sessions (see Chapter 4, “Sessions”)

• Templates (see Chapter 5, “Templates”)

• Resources (see Chapter 6, “Resources”)—administrator only

• Reports (see Chapter 7, “Reports”)

• Security (see Chapter 8, “Security”)—administrator only

• Settings (see Chapter 9, “Settings”)—administrator only

If you have problems while logging on, click the Contact technical support for help link. 

To log out of the system and return to the Active System Manager Logon page, click the Logout link (in 
the top right corner). For security reasons, you should always log out and then close your browser session.
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Home
C h a p t e r  3
Home 
This chapter describes the Active System Manager web interface Home page for the administrator and 
non-administrator users. The Home page displays, by default, after logging on to the Active System 
Manager software, either as an administrator user or a non-administrator user.

This chapter is organized in two main functions:

• Administrator User Functions

• Non-Administrator User Functions

Administrator User Functions

For administrator only tasks, the administrator icon is used to identify that sole role. For non-administrator 
tasks, no icon is used. 

The Active System Manager administrator can perform the following functions:

• Import, modify, delete, and save templates of all users

• Configure system-wide session notifications and reminders

• Cancel, modify, delete, and save (snapshot) sessions

• Start and stop ASAP Rescheduling and other scheduling properties

To view and access the administrator Home page options, log on as an administrator user. The 
Announcements page displays by default (see Figure 3-7 on page 3-8). 

The Home page displays the following options for the administrator user (see Figure ), in this order:

• Home > Dashboard (see Figure 3-1)

• Home > Announcements (see Figure 3-7)

• Home > Profile (see Figure 3-8)

• Home > Settings (see Figure 3-9)
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Administrator User Functions
Home > Dashboard
The Dashboard sub-menu displays current Active System Manager information in a way that is easy to 
read. 

To access the Dashboard page (Figure 3-1), log on as the administrator user, and on the Active System 
Manager Home page, click Dashboard.

Figure 3-1 Active System Manager Home > Dashboard (Administrator)

Managing Widgets
The Dashboard contains widgets that define your infrastructure in a specific layout. A widget is a 
stand-alone application that can be embedded into third party sites by any user on a page where they have 
rights of authorship (e.g. a page, blog, or profile on a social media site). Widgets allow users to turn personal 
content into dynamic web apps that can be shared on websites where the code can be installed.

The Active System Manager comes with a default set of widgets (10) already defined:
Table 3-1 Default Set of Widgets 

Widget Description

Resource Allocation By 
Session

Provides resource allocation data for sessions in a Running state. This 
report displays CPU and memory allocations grouped by sessions.

Resource Allocation by 
Host

Provides resource allocation data for hosts on which some virtual 
machine instances are provisioned in the current running sessions. This 
report displays CPU and memory allocations grouped by hosts.
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The following topics describe how to use and manage the Dashboard content:

• Adding a Widget

• Editing a Widget

• Customizing a Widget

• Refreshing Widget Content

• Maximizing or Minimizing a Widget

• Deleting a Widget

Resource Allocation By 
Group

Displays resource allocation data for virtual resources that are utilized 
in sessions owned by members of a group, grouped by an Active 
System Manager group name. This report also captures current group 
allocation, including CPU and memory allocation.
To configure: schedule a session with virtual machines (VMs) and the 
session owner should be part of one the groups. When the session is in 
a running state, the graph displays a grouped allocation of resources.

Top 10 Resource 
Allocation

Displays the top 10 users who currently consume a maximum of CPU 
and memory resources.

Top 10 Resource 
Utilization

Displays the top 10 hypervisor cluster resource utilization in the data 
center.

Virtual Machine (VM) 
Utilization per Session

Displays the most recent data (in percentage) for CPU and memory 
utilized on any VM, grouped by sessions. 
To configure: schedule a session with a VM and use the monitor 
operation to capture utilization data is present in RA. When the session 
is in a running state, it displays utilization in that specific session.

Host Utilization 
(Consolidated)

Displays information about how much capacity is utilized on a host by 
all running VMs with respect to the allocated capacity.

To configure: Open the Operations perspective, select a discovered 
host, and right-click to execute monitoring on that host.

Cluster Utilization 
(Consolidated)

Provides information about how much CPU and memory resources are 
utilized on a cluster by all running virtual machines, with respect to the 
allocated capacity.

Storage Utilization 
(Consolidated)

Provides storage utilization as a percentage of allocated storage for 
hypervisor clusters.

CPU/Memory Utilization 
Over Time Graph 

Displays CPU and memory utilization of hosts in percentage over a give 
period of time (eg. Weekly, 3Days,Daily, Hourly).

To configure: start monitoring on the host; utilization data will be pushed 
to the database, which will be retrieved, depending on time intervals.

Note More widgets will be added in future releases.

Table 3-1 Default Set of Widgets (continued)

Widget Description
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Adding a Widget
To add a widget, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Within the dashboard editor, on the top right, click the Add Widget link; see Figure 3-1.

The Widget Directory dialog box displays the widgets to select; see Figure 3-2.

Figure 3-2 Widget Directory

3. Select the widget to add and click Add it Now.

The view changes to refreshed display of the widgets, including the one you just added.

Editing a Widget
To edit a widget, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget, on the title bar, click the down arrow icon, and select Edit; see Figure 3-4.
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Figure 3-3 Deleting a Widget

Customizing a Widget
Each widget can contain specific filters and options to select to customize their display. To customize a 
widget’s display, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, on the title bar, click the down arrow icon, and select Edit; 
see Figure 3-4.

3. Select the required filter value and other options to customize the content.

Refreshing Widget Content
For some widget, the associated data does not refresh automatically, so you may be looking at stale 
information. 

To get an up-to-date representation of the widget data, you will need to refresh its content; perform the 
following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, on the title bar, click the down arrow icon, and select 
Refresh; see Figure 3-4.
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Maximizing or Minimizing a Widget
To maximize a widget, perform the following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, click the Edit layout link; see Figure 3-5.

2) Select a widget, on the widget title bar, select the window icon to maximize (or minimize, depending 
on which state the widget is in), which extends (or minimizes) the width and height of the selected widget. 
Alternatively, to minimize the widget, you can also click the down arrow icon, and select Minimize.

3) To reset the widget position, on the widget title bar, re-select the window icon.

Deleting a Widget
The dashboard can contain many different types of widgets. If you need to delete a widget, perform the 
following steps:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget, on the title bar, click the down arrow icon, and select Delete; see Figure 3-4.

Figure 3-4 Deleting a Widget
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Managing Dashboard Content
This section describes the following topics:

• Changing the Dashboard Layout

• Rearranging Dashboard Content

Changing the Dashboard Layout
Depending on how you want to view the Dashboard content, you can manipulate the layout as follows:

1. Open the Dashboard perspective and view the widgets, use one of the following methods:

• On the Active System Manager navigation menu, click Dashboard.

• On the Active System Manager menu bar, click Window > Open Perspective > Dashboard.

2. Select a widget. If the widget is empty, click the Edit layout link; see Figure 3-5.

Figure 3-5 Edit Layout Link

3. Select from one of the five proposed layouts; see Figure 3-6.

Figure 3-6 Edit Layout Options
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Rearranging Dashboard Content
To arrange your dashboard content, you can select and drag each widget to a new position. To do so, select 
the widget title bar and drag it to a new location on the dashboard.

Home > Announcements
Upon logging on to the Active System Manager web portal, the Announcements page displays 
(Figure 3-7), by default, with announcements (internal messaging) and lab information.

Figure 3-7 Active System Manager Home > Announcements Page (Administrator)
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Home > Profile
For the administrator, the Profile sub-menu facilitates grants access for administrators to view and edit the 
profile information and user access permissions of all users. To access the Profile page (see Figure 3-8 
example), log on as the administrator user, and on the Active System Manager menu bar, click Home > 
Profile. 

Figure 3-8 Active System Manager Home > Profile Page (Administrator)
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Home > Settings
The Settings sub-menu facilitates the administrator to set the schedular settings. It allows the administrator 
to turn on the ASAP Rescheduling. 

To access the Home > Settings page and set the scheduler properties, perform the following steps:

1. Log on as the administrator, and on the Active System Manager menu bar, click Home > Settings; see 
Figure 3-9.

Figure 3-9 Active System Manager Home > Settings Page (Administrator)

2. Click the Enable ASAP Rescheduling pull-down menu and select On. 

With ASAP Rescheduling turned on, when any sessions are canceled or completed early, the scheduler 
automatically attempts to reschedule all remaining sessions that were originally scheduled as ASAP. 

3. Configure the Minimum Rescheduling Interval values in Days, Hours, and Minutes.
Note The time between the remaining sessions and the new available time slot must be greater 

than the Minimum Rescheduling Interval.

4. Click Save.
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Non-Administrator User Functions

The functions described in this section are relevant for a non-administrator user. 

To view and access the non-administrator Home page options, log on as a non-administrator user. The 
Announcements page displays by default (see Figure 3-10).

The Home page displays the following options for the non-administrator user:

• Home > Announcements (see Figure 3-10)

• Profile (see Figure )

Home > Announcements
Upon logging on to the Active System Manager web portal, the Announcements page displays 
(Figure 3-10), by default, with announcements (internal messaging) and lab information.

Figure 3-10 Active System Manager Home > Announcements Page (Non-Administrator)
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Home > Profile
For non-administrator users, the Profile sub-menu grants access to view user profile details. To access the 
Profile page (see Figure 3-11 example), log on as a non-administrator user, and on the Active System 
Manager menu bar, click Home > Profile.

Figure 3-11 Active System Manager Home > Profile > Profile (Non-Administrator)
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The Profile page contains the following two tabs:

• Profile (see Figure 3-11 on page 3-12)

• Permissions (see Figure 3-12)

Profile
The Profile sub-menu allows non-administrator users to edit their profile information.

To access the Profile page, perform the following steps:

1. On the Active System Manager menu bar, click Home > Profile. 

Figure 3-11 on page 3-12 displays an example. The Profile sub-menu displays by default.

The following sections display on the Profile sub-menu: 

• Contact—Allows you to edit all user contact details, except the username.

• Member of the following groups (9)—Lists any groups to that you (the user) belong. 
(non-editable)

• Security—Allows you to change and verify your password

• Preferences—Allows you to edit the time zone preference.

• Maximum Session Duration—The scheduler enforces this maximum duration at the time of 
scheduling. This value is defined by your administrator. 

• Maximum Active Sessions—The scheduler enforces this maximum sessions at the time of 
scheduling. This value is defined by your administrator. 

2. Click Save after editing the required fields.

Permissions
The Permissions sub-menu allows non-administrator users to view their access permissions.

To access the Permissions page, perform the following steps:

1. On the Active System Manager menu bar, click Home > Profile > Permissions. 

The Permissions page displays for viewing access permissions profile, see Figure 3-12.
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Figure 3-12 Active System Manager Home > Profile > Permissions (Non-Administrator)

The Active System Manager permissions can only be edited by an administrator user. 
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Sessions
C h a p t e r  4
Sessions
A session editor allows you to view session-based resources and interact with session. When opening the 
session editor, the overall rendering looks similar to the underlying template, but resource type definitions 
are replaced by real inventory or virtual resources.

A session is a running session that has more features available to interact with your environment equipment. 

Managing Session Functions

This section describes the following sessions functions—all performed by the administrator.

For administrator only tasks, the administrator icon is used to identify that sole role. For non-administrator 
tasks, no icon is used. 

The Active System Manager administrator can perform the following functions:

• Create, modify, delete, and save templates of all users

• Configure system-wide session notifications and reminders

• Cancel, modify, delete, and save (snapshot) sessions

• Start and stop ASAP Rescheduling and other scheduling properties

To edit and manage the Sessions feature, on the Active System Manager menu bar, click the Sessions 
sub-menu; see Figure 4-1.
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Figure 4-1 Sessions 

Creating a New Session
To create a session, perform the following steps:

1. On the Active System Manager menu bar, click Sessions > New Session (see Figure 4-1).

The Create a New Session page displays; see Figure 4-2.
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Figure 4-2 Create a New Session

2. Click the Search for field and enter a template name to filter from the list of templates, or in the 
Templates table, select and click a specific template to display the Template Report for your selected 
template.
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3. Select a time frame to schedule the new template:

a. Click the Behavior field and select one of the following options: 

• As Soon As Possible (ASAP); see the “Configuring ASAP Rescheduling” section on page 4-8

• ASAP within fixed time frame

• Fixed start and end dates

• Permanent Session

• Group-based Session

• Recurring Session

b. Click the Duration field and modify duration time (in Days, Hours, and Minutes).

c. Click the Include Setup and Teardown time in overall scheduling time check box to enable the 
setup and teardown time in the scheduling. For more information about setup and teardown times, 
see the “Configuring Setup and Teardown Times” section on page 4-9.

Note You can adjust the scheduling behavior based on user preferences. The Scheduler can automatically 
perform extra scheduling when no solutions are reported, including identify preemption or running 
ASAP scheduling. For information about identifying scheduling issues, see the “Identifying 
Scheduling Issues” section on page 4-10.

4. Decide to continue to set more options or schedule with existing settings:

• Optional. Click Continue to display more options to set (see Figure 4-3) and go to step 5 on 
page 4-6.

The optional parameters for a session allows you to add participants to your session and include 
more detailed date/time instructions.

• Click Schedule with the settings you just configured and go to step a on page 4-6. (The scheduling 
results will display; see Figure 4-4 on page 4-7 for an example.)
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Figure 4-3 Scheduling Options
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5. Optional. If you clicked Continue, perform the following steps:

a. In the Participants section, select and organize participants; see the “Managing Participants via 
Custom Search” section on page 4-15.

b. Click OK to return to Figure 4-3 (scheduling options).

c. In the Scheduling section, prioritize and schedule results based on the following factors:

• Determine the number of time slot options requested: 1 (default), 5, 10, 20, 50.

• Determine the minimum time between options. The default value is 1 day and cannot be 
modified.

• Determine the scheduler priority: Multiple Times or Multiple Resources.

If you specify more than one time slot and also select the Multiple Times option, all of the 
solution time slots are for a different start time. The scheduler looks for a solution in each time 
interval possible and tries to provide as many time separated options as it can. The resources 
identified in all these solutions can be same or they may be different.

If you specify more than one time slot with the Multiple Resources option, then for every time 
interval possible, the scheduler tries to identify the maximum number of options possible in that 
time frame with different set of resources, until the maximum number of required solutions have 
been identified. If the number of solution-identified time slots are less than the required number 
of solutions, then the scheduler tries the next possible time slot and repeats the same cycle. The 
scheduler guarantees that if more than one solution is identified for a time slot, then each such 
solution differs in its resources. Solutions in different time slots may or may not have same set 
of resources.

• Identify preemption opportunities—When you set this option to Yes, if no perfect solution is 
identified, then the scheduler tries to identify solutions that can be achieved if existing sessions 
are canceled. For more information, see the “Preempting Sessions” section on page 4-14.

d. Select the Mode: Fixed or Moveable. 

e. Select the Priority; the default is 1.

6. Edit provisioning parameters.

7. Click Schedule to display the scheduling results; see Figure 4-4.
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Figure 4-4 Scheduling Results

8. In Figure 4-4, click Revise to return to the New Session page (Figure 4-2 on page 4-3) to modify your 
settings, or click Retry/Preemption to retry the configured settings; see Figure 4-5.
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Figure 4-5 Confirmed Status

Configuring ASAP Rescheduling
When you schedule a session, you may specify that you want to start the session as soon as all the required 
resources become available. This is called an ASAP session. The Active System Manager schedules the 
session at the earliest time it can find, and sets the entry’s state to Confirmed. If other sessions cancel or 
finish early, there is an opportunity for a previously confirmed ASAP session to move up to an earlier time 
slot.

ASAP does this automatically. This feature can be enabled or disabled by the Active System Manager 
administrator and its status is shown on the Active System Manager Welcome page. Typically, rescheduling 
occurs when a session is canceled or is edited to terminate early.
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ASAP rescheduling uses the following rules:

• Other sessions that have not begun and were originally scheduled in an ASAP manner are reviewed by 
the scheduler to determine if they can be advanced to an earlier start time, thereby optimizing or 
“repacking” the schedule.

• The scheduler considers confirmed ASAP sessions, one at a time, to attempt to find each an earlier time. 
It begins with the next session, based on the time that the session is due to start its setup period, rather 
than on the session start time.

• There is a configurable value (set by the administrator) used to determine the minimum “opportunity” 
time difference required before a session is considered for rescheduling. For example, if a session is 
scheduled to start five minutes from now, there would be no sense in trying to find an earlier time for it.

• Once the first candidate session is evaluated and is either changed or not changed, the remaining 
candidate sessions on the list are evaluated, one at a time, and given rescheduling opportunities based 
upon whether or not the prior sessions in the list have been cancelled or rescheduled.

• Email notification of schedule changes is provided. Email notification is sent to the session owner and 
participants. For more information on email notifications, see the Active System Manager User Guide.

After considering an ASAP session for rescheduling, the result is that it obtains either:

• The same resources at the same time because no better options were available.

• Different but equivalent (typed) resources at the same time.

• A better time with either the same or equivalent resources. A session never loses a time slot, or gets a 
later time slot, due to ASAP rescheduling.

Configuring Setup and Teardown Times
Active System Manager schedules setup time before a session becomes active. Similarly, teardown time is 
scheduled at the end of the session. Setup and teardown times are computed based on parameters specified 
in the Resource Type Specification files for each of the resources in your template.

Setup time is computed as follows:

• Active System Manager checks the setup time specified for each resource type in the template. It finds 
the longest time among them.

• Then it adds the template specified setup time. Thus, setup time is represented by the following 
equation: 

Setup time = (max (setup time in DTS for each resource in template) + 
template specified setup time)

Teardown time is computed as follows:

• Active System Manager checks the teardown time specified for each resource type in the template. It 
finds the longest time among them. 

• It then adds the template specified teardown time. Thus, teardown time is represented by the following 
equation:

teardown time = (max(cleanup time in DTS for each resource in template) 
+ template specified cleanup time)
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Setup and teardown times are added to the duration of the session. When creating a session, you can specify 
whether to include setup and teardown times within the defined time-frame for the session, or whether they 
can take place outside of the defined window. Setup takes place before the start of the session, and teardown 
takes place after the end.

Identifying Scheduling Issues
If all of the resources needed for your template are not available during the time period you request, the 
session cannot be scheduled. In this case, the Active System Manager scheduler gives you information 
about the nature of the resource that caused the session scheduling attempt to fail.

The scheduler provides as much information as possible about the failures in the Scheduled Session log 
output, which is automatically displayed. 

Some failures may not be detected until late in the scheduling process, and may not have simple causes. In 
these cases, you should try the session again with preemption turned on. This shows you other sessions that 
have resources that you need, or informs you if some of the resources you requested are unavailable.

If the scheduler finds that needed resources are not available, it gives you as much information as possible 
about the cause of the failure, and then the scheduler terminates.

The scheduler analyzes your template in five separate phases. If a problem is found in one phase, the 
scheduler reports it and does not continue to the next phase. The following list describes the five phases of 
the scheduling process:

• Phase 1: Identify Restrictions

• Phase 2: Identify Resources

• Phase 3: Evaluate Feasibility

• Phase 4: Identify Possible Time Frames

• Phase 5: Identify Solutions
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Figure 4-6 Scheduling Workflow

Phase 1: Identify Restrictions
This phase identifies restrictions enforced by the template. In this phase, you are provided information 
about the first instance of a resource incapable of being serviced by the requested session. You are also 
advised of candidates having locks on them due to existing sessions. This information is used in Phases 4 
and 5.

Phase 2: Identify Resources
This phase attempts to build a set of available resources for each requested template resource, either 
resources (resource types or resource instances) or resource interfaces. The scheduler reports the first 
failure, usually when it cannot identify any candidate for a requested resource in the template.

The following types of failure are identified in this phase:

• Resource of requested Manufacturer/Model not available—There is no resource of the requested 
Manufacturer/Model, either in the environment or within the requested restrictions of the session. In 
this scenario, you are prompted that no resource of the specified Manufacturer/Model is available. This 
phase does not generate an error if the requested resource exists in the environment, but it is being used 
by another session. (That error is reported in Phase 5 if you have enabled preemption.) Also, if there is 
not a sufficient quantity of the resource available, it is reported in Phase 3.

• Resource with requested property values not available—There are available resources of the 
requested Manufacturer/Model type, but none with the requested properties available. You are informed 
which property did not match for each candidate resource.
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For example, if your template contains resource TD1 for which you have required property P1 with 
value V1 and property P2 with value V2. You might be informed that there were no matches for this 
resource because:

— Candidate resource D1 did not satisfy property P1 with value V1

— Candidate resource D2 did not satisfy property P2 with value V2

• Resource with requested interface types not available—In this scenario, there might a resource 
satisfying the two preceding bulleted items, but one or more of its interfaces might not have any 
candidates available. This means that this resource cannot satisfy the request. For each candidate 
resource, you are informed of the first interface type that is unavailable on the candidate.

Phase 3: Evaluate Feasibility
This phase evaluates the candidates identified in Phase 2 for feasibility. For example, if your template 
requires two resources (created by type) whose manufacturer and model are “HP d330”, and if you have 
only one resource of that type in your environment (with asset tag “HPd330_1”). Phase 2 lists “HPd330_1” 
as a candidate for each of the two instances of this resource type in the template. Phase 3 concludes that 
there are not enough resources of the required type in the environment.

Similarly, it also checks that the required number of interfaces of each type are available on the candidate 
resources. For example, if a template resource has ten interfaces of type OC-3, and the environment has one 
resource of that type with five OC-3 interfaces. During Phase 2, for each requested interface there are five 
candidates (that is, each of the ten requested interfaces has a candidate list with the same five interfaces). 
However, you have requested ten interfaces, even though the environment resource has only five, so this 
request cannot be satisfied by this environment resource. This problem is detected during Phase 3. You are 
prompted that there was a request for ten interfaces of type OC-3, and for each of the candidate resources, 
the number of OC3 interfaces actually available is shown.

In this phase, the Active System Manager software reports only the first instance of feasibility failure. The 
scheduler exits at this point and reports the failure. Sometimes there are more complicated sets of 
requirements on a resource’s interfaces, where the scheduler determines that a candidate resource is not 
feasible, but where the problem is not so easily expressed. In these cases, Phase 3 states that the candidate 
resource does not satisfy the requirements. 

For example, if you have requested three OC-3 ports as follows:

• Port P1 has no properties enforced.

• Port P2 has property LOCATION=1A1 enforced

• Port P3 has property LOCATION=1A2 enforced

If the candidate environment resource D1 has these interfaces:

• Type OC3, location 1A1

• Type OC3, location 1A2

In this situation, Phase 2 produces the following candidates for the three requested OC-3 ports:

• P1 has candidates 1A1, 1A2

• P2 has candidates 1A1

• P3 has candidates 1A2
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The feasibility evaluation phase reports that D1 cannot satisfy the request, but the scheduler is unable to 
characterize the problem; therefore, environment resource D1 cannot satisfy the request.

Phase 4: Identify Possible Time Frames
This phase performs an evaluation of the scheduling time frame that you requested, and the applicable 
session time frames. You are prompted if there are no time frames possible, or if the resulting time frames 
are not a long enough duration. The information specifies whether the original time frame is insufficient, 
or whether the time frame resulting from the evaluation with session time frames is insufficient.

Phase 5: Identify Solutions
Phase 5 is composed of two passes:

• Pass 1: Possible Solutions—Possible solutions are attempted for the time slot, using the results of the 
previous phases. The scheduler also considers whether a environment resource is unavailable, because 
it is allocated to another session within the time slot.

• Pass 2: Preemption—It runs if Pass 1 fails to find a solution, and if you have enabled preemption for 
this session. It identifies possible solutions that use resources allocated to other sessions during this time 
slot.

Pass 1: Possible Solutions
Pass 1 checks all aspects of a candidate resource for your template, including some aspects that were not 
checked earlier. For example, it checks:

• Whether the resource is already allocated to another session during the time slot.

• Whether links are feasible; that is, for a template link between two resource interfaces, if the interfaces 
can be connected.

Pass 1 attempts to find the number of solutions that you requested. If it can only find a smaller number of 
solutions, it still considers this to be a successful run, and offers these choices to you rather than treating 
this as an error. If Pass 1 fails to find any solutions, and you have enabled preemption for this session, Pass 2 
runs.

Pass 2: Preemption
Pass 2 runs if Pass 1 of Phase 5 failed to find a solution and preemption was enabled for the session. It 
essentially repeats Pass 1, but this time the scheduler ignores resource unavailability due to sessions. It 
considers solutions that use resources that are used in other sessions.

The scheduler presents such a solution, describing requested resources that are used by other sessions, and 
identifies the sessions that block these resources. With this information, you can:

• Modify some existing sessions. (The session’s owner or the Active System Manager administrator may 
need to do this.)

• Change your requested template.

• Change your environment inventory (working with your Active System Manager administrator).

• Identify better environment resources and make the template more specific by using property-based 
scheduling or asset tag based scheduling.
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Note The Active System Manager software never presents more than one preemptive session candidate, 
regardless of whether you set the desired number of solutions to more than one when creating a 
session. The presented solution cannot be reserved until and unless either the blocking sessions are 
canceled or the requested template is modified and rescheduled. Multiple solutions are only 
considered during pass 1 of Phase 5; they are ignored during pass 2.

Displaying Error Conditions and Reports
The sessions list shows the status of sessions, and it also flags any sessions for which an error (or fault) has 
been detected. Active System Manager reports errors in several ways:

• The Active System Manager application notifies a user of faults detected on the current running session.

• For a user or an administrator, Active System Manager flags sessions for which faults have been 
detected.

Faults are indicated for running sessions with a red arrow button under the Report column. To find out more 
about the cause of an error, click the arrow button. The Session Resource/Error Report displays in a new 
window.

This report is available for each session on the In Progress list, whether or not it is in the Running state, 
and whether or not faults have been detected for it. It lists general information for the sessions, followed by 
a section for each resource.

For each resource, the following information is shown:

• The Name, Model, Manufacturer, and Asset Tag of the resource.

• Any Error condition that has been detected on the resource.

• A list of interfaces on the resource that are used in this session, identifying each by its Location and 
Type. The letter A at the start of the line indicates whether the port was inserted during template creation 
using the template perspective. Otherwise, it indicates that the interface is part of a working protect or 
trunking relationship. If the port is part of a trunk group, the letter T displays in the Relationship 
column. If the port is part of a Working-Protection group, then a W or P displays, indicating its role.

Preempting Sessions
In a typical session, the Active System Manager session manager software looks for available resources to 
fulfill session requests. Resources are shared on a first-come-first-served basis.

Sometimes, the resources required for your session have already been assigned to other sessions. You can 
find out whether your session would succeed if those resources were available by using a preemptive 
session. In a preemptive session, the Active System Manager scheduler informs you of previously 
scheduled or currently running sessions that have reserved the resources that you require. Then 
environment administrators can cancel the interfering sessions, or take the necessary actions to terminate 
running sessions to meet the needs of top priority tasks.

For more information about how the Active System Manager scheduler implements preemption, see the 
“Filtering Sessions” section on page 4-19 and the “Sorting Sessions” section on page 4-21.
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The rules of preemption are as follows:

• The Active System Manager notifies you of sessions that prevent your preemptive session from being 
scheduled. It does not actually cancel these sessions for you, and the preemptive session is not 
scheduled.

• You must take necessary actions to cancel sessions that conflict with the preemptive session. As a 
preferred practice when cancelling an active session, you should first notify session participants and 
warn them to do a “Save As” in the Active System Manager application to save the state of their 
template.

• Sessions may only be cancelled by the owner of the session, or by a Active System Manager 
administrator.

• When conflicting sessions have been removed, the session should be created again.

Managing Participants via Custom Search 
In many of the procedures for managing user profiles, topologies, and sessions, there is an option to add 
participants and search, sort, edit, or remove participants (users or groups). 

As a standard search for participants, for example, the Participants section allows you to select and 
organize participants, as necessary, and click Edit or Remove to edit or remove participants (see 
Figure 4-7) based on your search results.
Sessions 4-15



Managing Session Functions
Figure 4-7 Selecting Participants to Edit or Remove

On this page, you can perform one of the following tasks to select and organize participants:

• Click the Search field and type a participant to filter out the list (by user or group). 

• Click the Advanced Search option (see Figure 4-8) to narrow your criteria using the basic web filtering 
options (see Table 4-1). 

Figure 4-8 Advanced Search

Table 4-1 Filtering Options

Filtering 
Option Description

Contains Indicates that the search criteria contains the string entered.

Is Indicates that the search criteria must match the string entered.

• From the Search Results section, select and organize participants, as necessary and click Add or 
Remove to add or remove participants based on your search results.
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As you edit participants to your list, those participants display in the Added Participants section; see 
Figure 4-7. Participants added to a template (or session) are not allowed to cancel or edit it, but they can 
view it or enter its environment template (or session). The same is true for members of groups that are 
added as participants; they can also view or enter the template (or session). When participants join an 
environment template (or session), their actions are controlled by their user IDs. They are only allowed 
to perform Active System Manager application functions for which they have permission. Your Active 
System Manager administrator can verify what permissions have been granted to a user.

Purging Sessions
To purge a session, perform the following steps:

1. On the Active System Manager menu bar, click Sessions > Purge Sessions (see Figure 4-1) to display 
the list of sessions (Figure 4-9).

You are prompted to confirm the purging of the sessions; see Figure 4-9.
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Figure 4-9 Purge Sessions

2. Select the sessions to purge and click Submit, which will permanently delete and purge those selected 
sessions from the database. 

Note All session utilization data captured by the Monitoring Engine will be purged and deleted. 
Once a session has been purged, it cannot be retrieved.
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Filtering Sessions
To filter search results for sessions, perform the following steps:

1. On the Active System Manager menu bar, click Sessions > Custom Filtering (see Figure 4-1) to 
display the Custom Filtering page; see Figure 4-10.

Figure 4-10 Custom Filtering

2. Select the Contains/Is filter (see Table 4-2), as necessary, and enter a Session Name.

3. Enter a Start Time and apply the Starting after/Starting before filter, as necessary.

4. Enter an End Time and apply the Starting after/Starting before filter, as necessary.

5. Click Add More Filters to display and configure more filtering options; see Figure 4-11.
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Figure 4-11 Add More Filters

a. Enter an Owner name and apply the Contains/Is filter, as necessary.

b. Enter a Template name and apply the Contains/Is filter, as necessary.

c. Enter the Creation Time and apply the Created after/Created before filter, as necessary.

d. Enter the Session Status and apply the Cancelled/Cleaning Up/ Completed/ Confirmed/ Failed/ 
Running/ ALL/Setting Up/Snapshot/Wait Setting Up filter, as necessary.

6. Click Apply Filter to execute filter and display displays search results that satisfy your criteria, or click 
Clear Filter to clear entry settings and restart your filtering configuration. (The Clear Filter button 
does not affect the entries currently listed on the page.)

The Filter Off button displays the status of filter as On or Off. Using the Filter Off and Filter Off 
buttons, you can screen items to display by filtering, and sorting the order presented. 

Table 4-2 lists and define the basic web filtering options. 

Table 4-2 Web Filtering Options

Filtering 
Option Description

Contains Indicates that the search criteria contains the string entered.

Is Indicates that the search criteria must match the string entered.
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Table 4-3 lists and defines the buttons/functions that are shared on each filter management page.

Table 4-3 Filter Management Common Functions 

Button Button Name Description

Clear Filter Clears the entry settings and starts over with your filtering 
configuration. The Clear Entries button does not affect the entries 
currently listed on the page. To remove the filter, you must also click 
Save & Apply.

Apply Filter Indicates that the filter is executed and displays the entries that satisfy 
your criteria.

 

Sorting Sessions
You can sort a list by clicking the column that you want the entries to be sorted by, in the same way that 
many Windows applications use to sort output lists. To sort a column, click the column title. To switch from 
ascending to descending order, or vice versa, click the title again. The sorting that you set up for a page 
usually persists for your user session. You can also change the sorting order used for presenting entries.

To sort sessions search results, perform the following steps:

1. On the Active System Manager menu bar, click Sessions. 

2. Click any arrow displayed beside each column header to sort results in ascending or descending order; 
see Figure 4-12.

Figure 4-12 Sort Header

Navigating Sessions
To navigate to the Sessions page results, perform the following steps:

1. On the Active System Manager menu bar, click Sessions.

2. Click the navigation panel to select number of records to be displayed per page; see Figure 4-13.

Figure 4-13 Navigation Panel

3. Click the up or down arrow to navigate the pages sequentially.
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Deleting Sessions
Note In Progress and Confirmed sessions must first be cancelled before they can be deleted.

To delete one or more sessions, perform the following steps:

1. On the Active System Manager menu bar, click Sessions.

2. Select the check box in the Batch column next to each session to delete, and then click Delete.

You are prompted to confirm the selected deletion; see Figure 4-14.

Note For sessions only, if the Purge check box is unchecked, the session utilization data captured 
by the Monitoring Engine remains in the database to include in utilization reports.

Figure 4-14 Delete Sessions

3. Click the Don’t Show Me this prompt the next time I delete a session check box to skip this 
confirmation page in the future.

4. Click Delete to confirm the session deletion. 
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Figure 4-15 Session Related Actions in Running Status

Figure 4-16 Session Related Actions in Confirmed Status

Figure 4-17 Session Related Actions in Remaining Status

Stopping Sessions
To stop a session while it is in a Running state, perform the following steps:

1. On the Active System Manager menu bar, click Sessions.

2. Select a session, in the Action column, click the Select Action drop-down list, and select Stop.

You are prompted to confirm stopping the session; see Figure 4-18.
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Figure 4-18 Stop Session

3. Click Stop Session to stop the session and return to the previous page.

Editing Sessions
To edit a session, perform the following steps:

1. On the Active System Manager menu bar, click Sessions to display the existing sessions.

2. Select a session, in the Action column, click the Select Action drop-down list, and select Edit.

The Edit Session page displays; see Figure 4-19.
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Figure 4-19 Edit Sessions

3. Optional. Click the Name field and update the session name.

4. Optional. Click the Select Owner field and select another owner (if available).

5. In the Extra Time section, modify the session time currently configured:

a. Modify the Start Date and End Date, including Hours and Minutes.

b. Modify the Time Zone, as appropriate. 
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The scheduler processes all requests with respect to GMT. Your entry in this field determines how 
the time zone for all activity calculates and displays. For example, assume that the Active System 
Manager server is located on the West coast (Pacific time). A session is scheduled to begin at 10:00 
a.m. Pacific time. If a user on the East coast has a time zone display set for EST, the session appears 
to start at 1:00 p.m. EST.

6. Optional. In the Participants section, select and organize participants; see the “Managing Participants 
via Custom Search” section on page 4-15. 

7. Click OK to return to Figure 4-19 (editing session options).

If available, the Properties section displays all custom-level session properties for your environment. 
These properties are customized by your administrator. Some properties are required; some are 
optional. Those marked with an asterisk (*) are required.

8. Click Save to save the modified settings.

Creating a Snapshot of a Session
To create a snapshot of a session, perform the following steps:

1. On the Active System Manager menu bar, click Sessions to display the existing templates.

2. Select a session, in the Action column, click the Select Action drop-down list, and select Snapshot.

A snapshot view of the template displays; see Figure 4-20.
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Figure 4-20 Session Snapshot

3. In the Template section, modify the following parameters:

a. Optional. Add a description for the template name referenced.

b. Select a save option for the template:

• Save all resources as specific resource instances

• Save all resources as generic resource types

• Save resources as originally authored

4. In the Overwrite section, click to select (or de-select) the following options:

• Overwrite the template is already exists

• Keep existing history details

5. Click Save.
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Auditing an Existing Session
To view or audit an existing session, perform the following steps:

1. On the Active System Manager menu bar, click Sessions to display the existing sessions.

2. Select a session, in the Action column, click the Select Action drop-down list, and select Audit.

Figure 4-21 displays an example of a session report to audit.

Figure 4-21 Session Audit Report (Example)
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Canceling a Session
To cancel a session, perform the following steps:

1. On the Active System Manager menu bar, click Sessions to display the list of sessions.

2. Select a session, in the Action column, click the Select Action drop-down list, and select Cancel.

The Cancel Session page displays; see Figure 4-22.

Figure 4-22 Cancel Session

Downloading Log Files
This function downloads the session log file, including all Resource Adapters and execution logs.

To download a log file, perform the following steps:

1. On the Active System Manager menu bar, click Sessions to display the list of sessions.

2. Select a session, in the Action column, click the Select Action drop-down list, and select Download 
Logs.

You are prompted to download the selected files. The content is automatically saved as a .txt file. 
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Performing a Join Session Operation
In a running session, you can perform a join operation. To join a session in a Running state, perform the 
following steps:

1. On the Active System Manager menu bar, click Sessions to display the existing sessions.

2. Select a running session, and in the Status column, click .

The Join Sessions page displays with the Overview sub-menu open, by default; see Figure 4-23.

Figure 4-23 Joining a Session
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Table 4-4 describes the available options to join sessions.

Table 4-4 Join Session Components

Component Description

Overview Provides an overview for the specified session:
• Session ID
• Session name
• Session status (see Table 4-5)
• Template Name
• Setup Start Time
• Requested Start Time
• Requested End Time

• Session Start Time
• Session End Time
• Teardown End Time
• Duration
• Owner
• Participants (Users and Groups)

Resources Provides a listing of resources and applications available to launch. Resources that have a link 
support elasticity. For an example, see Figure 4-25 on page 4-32. See Table 4-6 on page 4-33 for 
more details.

Diagram Provides reference renderings of the template for the specified session; see Figure 4-24 on 
page 4-32 for an example.

Table 4-5 defines the session status while processing a session request.

Table 4-5 Session Status 

Status Description

Confirmed A validated and scheduled session.

Running A session that has started.

Wait Setting Up A scheduled setup time has arrived, but some of the resources required by the session have 
not yet been released by earlier sessions.

Setting Up The process of scheduling resources and laying down the required configuration files for a 
session.

Cleaning Up The process of restoring the original settings for a session.

Snapshot Takes the snapshot the running session and saves the modified template.

Completed A session that has completed the start to end time.

Failed A session that did not get realized or problems occurred during the cancel operation.

Canceled A session canceled by the user or system.

Deleted A session deleted by the user.
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Figure 4-24 Diagram View

Figure 4-25 Resources View

3. In the Resources column, click a link to launch an application for the associated resource.

The application displays the System, Custom, and Applications tabs; see Figure 4-26.
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Figure 4-26 Resources sub-menu Properties—System, Custom, Applications

Table 4-6 defines the Resources sub-menu properties.

Table 4-6 Resources sub-menu Properties

sub-menu 
Name Definition

System System-level RA methods/operations that can be invoked from both the web application and the 
Active System Manager application. 

Custom Custom-level RA methods/operations that can be invoked from the web application and the Active 
System Manager application. These operations are typically an extension of built-in RA capabilities. 
These operations are required to access Active System Manager RA SDK.

Applications RA applications that can be launched from both the web and Active System Manager application; for 
example, launching an SSH console or RDC into the resource.

The resource name is a hotlink that allows you to execute the resource operations. If the resource 
role is virtual, then you can extend its capacity; click the Enabled link in the Elasticity column (see 
Figure 4-25). The Elasticity dynamic properties display (as a sample) in Figure 4-27.
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Figure 4-27 Dynamic Properties—Elasticity

4. Set new property values.

5. Optional. Click the Allow resource relocation on different server check box to move your resource 
on a different host/hypervisor.

6. Click Update for the session to take effect.
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Templates
C h a p t e r  5
Templates
Managing and maintaining templates for the Active System Manager portal is the most crucial task for the 
Active System Manager administrator. Regular maintenance ensures the smooth running of the entire 
Active System Manager software suite.

To edit and manage the Active System Manager Templates feature, click the Templates sub-menu; see 
Figure 5-1.

As an administrator, you can view all of the current templates. 
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Figure 5-1 Templates 

Managing Template Functions

The following sections describe template-related functions:

• Importing Templates

• Filtering Templates

• Navigating Templates

• Sorting Templates

• Viewing an Existing Template

• Editing Templates

• Exporting Templates

• Reserving Templates

• Deleting Templates in Bulk
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Importing Templates
To import a template, perform the following steps:

1. On the Active System Manager menu bar, click Templates > Import to display the Import Template 
page; see Figure 5-2.

Figure 5-2 Import Template

2. Click Choose File, select a valid template file (.xml) from your computer, and click Browse > Open.

If available, the Properties section displays all custom-level template properties for your environment. 
These properties are customized by your administrator. Some properties are required; some are 
optional. Those marked with an asterisk (*) are required.

3. Click Import to import your new template into your library.
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Filtering Templates
To filter search results for templates, perform the following steps:

1. On the Active System Manager menu bar, click Templates > Custom Filtering to display the Custom 
Filtering page; see Figure 5-3.

Figure 5-3 Custom Filtering

2. Click the Template Name field and apply the Is or Contains filter, as necessary.

3. Click the Updated Time field and apply the Updated after or Updated before filter, as necessary, and 
select a date to use for that time filter.

4. Enter Author and apply the Is or Contains filter, as necessary.

5. Click Add More Filters to add more filters.

6. Click Apply Filter to execute filter and display search results that meet your criteria, or click Clear 
Filter to clear entry settings and restart your filtering configuration. 

The Clear Filter button does not affect the entries currently listed on the page.

The Filter Off button displays the filter status as On or Off. Using the Filter Off and Filter Off 
buttons, you can filter and sort items to display. 
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Navigating Templates
To navigate to the Templates page results, perform the following steps:

1. On the Active System Manager menu bar, click Templates.

2. Click the navigation panel to select number of records to be displayed per page, see Figure 5-4.

Figure 5-4 Navigation Panel

3. Click the up or down arrow to navigate the pages sequentially.

The Templates navigation feature lets you directly select which page of this list to view. To select a 
particular page in the list, click the Page link, and select a page from the drop-down list.

Sorting Templates
You can sort a list by clicking the column to sort, in the same way that many Windows applications use to 
sort output lists. To sort a column, click the column title. To switch from ascending to descending order, or 
vice-versa, click the column title again. The sorting that you set up for a page remains for your user session. 
You can also change the sorting order used for presenting entries.

To sort template search results, perform the following steps:

1. On the Active System Manager menu bar, click Templates.

2. Click on any arrow displayed besides all headings in the header to sort results as per the clicked heading, 
see Figure 5-5.

Figure 5-5 Sort Header
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Viewing an Existing Template
To view an existing template, perform the following steps:

1. On the Active System Manager menu bar, click Templates.

2. Select a template, in the Action column, click the Select Action drop-down list, and select View to 
display the Template Report page displays.

Table 5-1 lists and defines the components on the Template Report page.

Table 5-1 Template Components Available in View Mode

Template Component Description

Overview A general template description of a template. It can also include the setup time, 
teardown time, setup script, teardown script. As you scroll down the page, you can 
view the other template components listed in this table.

Rendering An associated diagram or drawing that illustrates the specified template.

Notes General notations for the specified template, including the date and time the 
template was created, the template owner, and any additional notes that the 
template owner includes.

Properties Optional. Depending on your template, this component may not be available. 
When it is available, it displays custom properties for the template if available.

Provisioning Properties Optional. Depending on your template, this component may not be available. 
When it is available, it includes the custom provisioning properties associated to 
that template.

Attachments Includes any graphics or files that support the specified template.

Resources—Summary Includes resources available for that template, including Name, Authored By, Asset 
Tag (Version), Manufacturer, Model, Shared or Exclusive, Description.

Resources—Detailed Reports Includes detailed information for each component listed as “Name” for that 
template. Information includes provisioning properties, port-level properties, 
interface definitions, images associated to element names, and link information.

Table 5-2 lists and describes the template details of a template report. 

Table 5-2 Template Details 

Category Field Description

Template Report Overview The fields in this section apply to the whole template.

Description Description text entered when the template was created.

Setup Time (minutes) Time allowed for setup, in minutes, before a session 
becomes active.

Teardown Time (minutes) Time allowed for cleanup, in minutes, at the end of the 
session.

Setup Script A script that is run before a session becomes active.

Teardown Script A script that is run at the end of the session.

Resources—Summary
Resources—Detailed 
Report

Name Name of the resource.

Authored by Whether the resource was added to the template by 
Resource Type or by Resource Instance (by asset tag).
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Asset Tag (Version) This field is present if the resource was created by Asset 
Tag. The selected piece of equipment in the environment 
is uniquely identified by its Asset Tag and version number 
of the resource.

Manufacturer & Model Specifies the resource type.

Shared Element If Yes, this resource may be shared by multiple concurrent 
sessions.

Description Resource description. If Configuration Parameters (such 
as run-time image name) have been defined for the 
resource, they are shown in their own section.
If properties for property-based scheduling have been 
defined for the resource and its interfaces, they are 
displayed in their own section. Each property lists the 
value and equation it must satisfy, the category of 
property, and whether the property is preferred or 
enforced for scheduling. For more information on 
properties, see the Active System Manager User Guide.

Interface Definitions Name Name of the interface.

Type Interface type.

Location The location of the port on the resource. If there is a 
Working-Protect relationship in effect for this interface, its 
name is followed with “(W)” or “(P)”.

Link to If there is a link defined on this port, the other end of the 
link is shown here as a hyperlink. Clicking on it displays 
the section of the window that contains the port at the 
other end of the link.

Description A string describing the interface, if any. 

Link Information Name Name of the link.

Link Type Simple or Trunk.

Description A string describing the interface, if any.

From Resource Resource asset tag.

From Interface Resource interface name.

From Location Resource interface location name.

To Resource Resource asset tag.

To Interface Resource interface name.

To Location Resource interface location name.

Status Resource Interface Status

Table 5-2 Template Details (continued)

Category Field Description
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Editing Templates
To edit templates, perform the following steps:

1. On the Active System Manager menu bar, click Templates.

2. Select a template, in the Action column, click the Select Action drop-down list, and select Edit.

The Edit Template page displays; Figure 5-6.

Figure 5-6 Edit Template

Note By default, the template name cannot be modified.

3. Optional. Click the Owner Name field and update the template owner.

4. Optional. In the Participants section, select and organize participants; see the “Managing Participants 
via Custom Search” section on page 5-9.
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5. Click OK to return to Figure 5-6 on page 5-8 (scheduling options).

6. Select a Permissions option (Update or Delete), as appropriate. 

Editing allows you to share the selected template to other users and groups.

7. Click Save to save the modified settings.

Managing Participants via Custom Search 
In many of the procedures for managing user profiles, templates, and sessions, there is an option to add 
participants and search, sort, edit, or remove participants (users or groups). 

As a standard search for participants, for example, the Participants section allows you to select and 
organize participants, as necessary, and click Edit or Remove to edit or remove participants (see 
Figure 5-7) based on your search results.

Figure 5-7 Selecting Participants to Edit or Remove

On this page, you can perform one of the following tasks to select and organize participants:

• Click the Search field and type a participant to filter out the list. 

• Click the Advanced Search option (see Figure 5-8) to narrow your criteria using the basic web filtering 
options (see Table 5-3). 
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Figure 5-8 Advanced Search

Table 5-3 Filtering Options

Filtering 
Option Description

Contains Indicates that the search criteria contains the string entered.

Is Indicates that the search criteria must match the string entered.

• From the Search Results section, select and organize participants, as necessary and click Add or 
Remove to add or remove participants based on your search results.

As you edit participants to your list, those participants display in the Added Participants pane; see 
Figure 5-7. Participants added to a template (or session) are not allowed to cancel or edit it, but they can 
view it or enter its environment template (or session). The same is true for members of groups that are 
added as participants; they can also view or enter the template (or session). When participants join an 
environment template (or session), their actions are controlled by their user IDs. They are only allowed 
to perform Active System Manager application functions for which they have permission. Your Active 
System Manager administrator can verify what permissions have been granted to a user.

Exporting Templates
To export a template, perform the following steps:

1. On the Active System Manager menu bar, click Templates.

2. Select a template, in the Action column, click the Select Action drop-down list, and select Export.

3. Click Save to save the file to your local desktop.

The Export Template_Example of a Single Template Definition page displays; see Figure 5-9.
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Figure 5-9 Export Template_Example of a Single Template Definition

The export output displays in a separate window or can be saved to your desktop; see Figure 5-9 for an 
example.
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Reserving Templates
To reserve a new template, perform the following steps:

1. On the Active System Manager menu bar, click Templates.

2. Select a template, in the Action column, click the Select Action drop-down list, and select Reserve.

The New Session page displays; see Figure 5-10.

Figure 5-10 New Session

3. Select a template from the list, or from the Search field to filter the list. Click any particular template 
in the list to display the Template Report for your selected template.

4. Select a time frame to schedule the new template:

• Behavior: As Soon As Possible (ASAP), ASAP within fixed time frame, Fixed start and end date, 
Permanent Session

• Duration: Days, Hours, Minutes
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• Include Setup and Teardown time in overall scheduling time

Note You can adjust the scheduling behavior based on user preferences. The Scheduler can automatically 
perform extra scheduling when no solutions are reported, including identify preemption or running 
ASAP scheduling.

5. Decide to continue to set more options or schedule with existing settings:

• Optional. Click Continue to display more options to set (see Figure 5-11) and go to step 6 on 
page 5-14.

The optional parameters for a template allows you to add participants to your session, disable the 
OS image load at the beginning of the session, and include more detailed date/time instructions.

• Click Schedule with the settings you just configured and go to step 7 on page 5-15. (The scheduling 
results will display; see Figure 5-13 for an example.)
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Figure 5-11 Scheduling Options

Note Required properties must be set before scheduling can occur.

6. Optional. If you clicked Continue, perform the following steps:

a. In the Participants section, select and organize participants; see the “Managing Participants via 
Custom Search” section on page 5-9.
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b. Click OK to return to Figure 5-11 (scheduling options).

c. In the Scheduling section, prioritize and schedule results based on the following factors:

• Determine the number of time slot options requested: 1 (default), 5, 10, 20, 50.

• Determine the minimum time between options. The default value is 1 day and cannot be 
modified.

• Determine the scheduling priority: Multiple Times or Multiple Resources.

If you specify more than one time slot and also select the Multiple Times option, all of the 
solution time slots are for a different start time. The scheduler looks for a solution in each time 
interval possible and tries to provide as many time separated options as it can. The resources 
identified in all these solutions can be same or they may be different.

If you specify more than one time slot with the Multiple Resources option, then for every time 
interval possible, the scheduler tries to identify the maximum number of options possible in that 
time frame with different set of resources, until the maximum number of required solutions have 
been identified. If the number of solution-identified time slots are less than the required number 
of solutions, then the scheduler tries the next possible time slot and repeats the same cycle. The 
scheduler guarantees that if more than one solution is identified for a time slot, then each such 
solution differs in its resources. Solutions in different time slots may or may not have same set 
of resources.

• Identify preemption opportunities—When you set this option to Yes, if no perfect solution is 
identified, then the scheduler tries to identify solutions that can be achieved if existing sessions 
are canceled. 

7. Click Schedule to display the resulting page; see Figure 5-12.
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Figure 5-12 Scheduler Settings
5-16 Active System Manager Web Interface User Guide, Release 7.0



Managing Template Functions
You receive one of three possible responses at this time:

• If the request can be satisfied, you see a list of session time options.

• If a non-preemptive request cannot be satisfied, you are informed of this. For an explanation of how 
the scheduler works, and how to resolve problems encountered in scheduling sessions, see 
“Identifying Scheduling Issues” section on page 4-10

• If other sessions conflict with a preemptive request, a list of possible sessions using resources 
already assigned to other sessions displays.

These cases are described as follows:

• If the equipment you requested in your template is available, the New Session dialog displays. 

• In addition to possible start and end times, the setup and clean up time needed for your template 
display. These times are computed based on setup and cleanup times specified for each resource type 
in the template by its resource file.

• Select the session that you prefer. Your choices are displayed sorted by start time. To see the 
Scheduled Session Results Report, which shows the resources that were used in the selected session 
solution, click View.

8. Optional. In the Session Name field, enter a name for the session. If not entered, a default name will be 
assigned at the time of session creation.

If available, the Provisioning Properties section displays all custom-level session properties for your 
environment. These properties are customized by your administrator. Some properties are required; 
some are optional. Those marked with an asterisk (*) are required.

9. Click Revise to modify your settings, or click Reserve to schedule this template.

The list of sessions display by default; see Figure 5-13.

Figure 5-13 Confirmed Status
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Deleting Templates in Bulk
To delete one or more templates, perform the following steps:

1. On the Active System Manager menu bar, click Templates.

2. Click to select the Delete check box next to each template to delete, and then click Delete.

You are prompted to confirm the selected deletion; see Figure 5-14.

Figure 5-14 Delete Template

3. Click the Don’t Show Me this prompt the next time I delete a template check box to skip this 
confirmation page in the future.

4. Click Delete to remove the selected template.
5-18 Active System Manager Web Interface User Guide, Release 7.0



Resources
C h a p t e r  6
Resources
The Active System Manager administrator can define new resources and resource types, and modify 
various parameters for the resources in the environment by using the Resources (menu) functions. This 
chapter describes the three resource types available in the Active System Manager software, as well as their 
respective functionality.

Before you add equipment to your resources, information describing a resource type must already have 
been added to the Active System Manager application. The process of adding a resource type to the Active 
System Manager is called integration, and resource types that have been successfully added are said to be 
integrated. The Active System Manager web portal allows for adding and managing resources, and 
integrating and managing resource types.

Note All types of resources that are listed on the Resources sub-menu can be sorted and filtered. 
The only way to create, add, or modify all resource types, and manage and control 
equipment, is with the Inventory perspective. The Inventory perspective creates links 
between control and managed equipment. For more information, see the Active System 
Manager Online Help.

When a resource has been added to the Active System Manager application, it becomes part of the 
Inventory. Inventory consists of three components:

• Resources > Managed

• Resources > Control

• Resources > Resource Type

Resources > Managed

Managed resources have been added to the inventory and are visible to the scheduler for possible inclusion 
in a session. These resources are available to be added into a template with the Templates perspective. 
These include a special type of resource, called a composite resource. A composite resource is made up of 
components. 

These components are part of the Active System Manager’s inventory, but they can only be viewed or 
managed in the Inventory perspective; they are not visible using the browser interface. For more 
information on composite resources and components, see the Active System Manager Online Help.
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Resources > Managed
To access the managed equipment, currently available in the inventory, on the Active System Manager 
menu bar, click Resources. 

The Managed page displays (by default) the list of managed equipment currently available in the 
inventory; see Figure 6-1:

• Manufacturer and Model—Information for this resource.

• Asset Tag—Code that uniquely identifies a particular piece of equipment.

• Ver.—Resource version number.

• Name—Name of a particular piece of equipment.

• Action—View, Update and Export actions on that particular resource.

• Batch—Option to select Resource for deletion either single or in bulk.

Figure 6-1 Managed Equipment (Resources)
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The following operations can be performed on a Managed Equipment Resource type:

• Creating Managed Equipment

• Updating Managed Equipment Links

• Filtering Managed Equipment

• Navigating Managed Equipment

• Sorting Managed Equipment

• Deleting Batch Operations

• View, Update, or Export Resources

Creating Managed Equipment
Before adding a resource to your inventory, its resource type must already be known to the Active System 
Manager application. For more information, see the “Creating a New Resource Type” section on page 6-22.

To add managed equipment to the environment, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Managed > New to add managed 
equipment to display the Import Resource Inventory page; see Figure 6-2.

Figure 6-2 Import Resource Inventory

2. Click Choose File to select a valid resource type file from your computer. 

This file will be imported into your environment as a new resource.

3. In the Domain section, select a domain to associate with the resource, and select a valid domain (central 
or remote).
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4. Click Import. 

When the resource is successfully integrated, the updated resource displays. You may need to click to 
an earlier or later page in the list to find the new imported resource. 

Note The first resource you import for a specific type of equipment automatically becomes active.

Updating Managed Equipment Links
For each connection, the DISLINK lists an interface on a “from” resource that is connected to an interface 
on a “to” resource. Each resource interface is specified by the location associated within its resource type 
file. When you add a new piece of managed or control equipment to your environment, Active System 
Manager must be informed of any changes to the physical connections in the environment.

The first time that you add links to the Active System Manager application, you may create one DISLINK 
file or a set of files to include all of the connections currently present in your environment. It is a matter of 
convenience whether to enter all of your connections in one file, or group sets of connections in separate 
files to be added separately. When you add equipment, you can create a new DISLINK file that reflects just 
the new connections that you have added.

Note When Active System Manager performs an update links operation, it builds on the 
connections that it has already learned, so it adds the new links to its existing database. 
Repeating a connection is acceptable; it does not cause any problems. 

If you remove some connections in the environment, you can tell Active System Manager to do the same. 
Just create a DISLINK file with the links to be removed, and tell Active System Manager to disconnect 
them as described in the following procedure. If you are changing existing connections, disconnect the old 
links in Active System Manager before adding the new links, to make it easier to keep track of what you’ve 
done.

To add or remove links in your environment, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. Click Update Links to display the Import Links Definition page; see Figure 6-3.
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Figure 6-3 Update Links 

3. In the Operation section, connect or disconnect the links listed in your DISLINK file:

• Click the Connect Links option to add the links.

• Click the Disconnect Links option to “subtract” the links from the database.

4. Depending on your browser, in the Choose Connection File section, click Browse (or click Choose 
File) to navigate to the DISLINK file. 

5. Click Import. 

When the links are successfully updated, you are returned to the Managed Equipment list.

Note There is never a problem with conflicting links. Whenever a different connection is 
specified for an interface with an existing link, the new connection overrides it.

Filtering Managed Equipment
To filter search results for Managed Equipment, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. Click Custom Filtering. The Custom Filtering page displays; see Figure 6-4.
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Resources > Managed
Figure 6-4 Custom Filtering

3. Click the Manufacturer, Display Name, and Model drop-down lists, as appropriate, and apply 
contains or is filter.

4. Click Apply Filter to display search results after filtration.

The Filter Off button displays the status of filter as On or Off.

Navigating Managed Equipment
To navigate Managed Equipment result pages, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. Click the navigation panel to select number of records to be displayed per page; see Figure 6-5 as an 
example.

Figure 6-5 Navigation Panel

3. Click the forward or backward arrow to navigate to pages sequentially, or click Page to display a 
drop-down a list of all pages. Click the page number to navigate to directly.
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Sorting Managed Equipment
To sort managed equipment search results, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. Click any arrow displayed next to a heading row to sort results; see Figure 6-6 where you can click an 
arrow next to any of the headings displayed.

Figure 6-6 Sort Heading Row

Deleting Batch Operations
To delete one or more resources in batches/bulk, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. In the Batch column, select one or more resources to delete and click Delete; see Figure 6-7.

Figure 6-7 Deleting Batch Operations

The Delete page displays; see Figure 6-8.
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Figure 6-8 Deleting Batch Operations

3. If required, click the Don't show me this prompt the next time I delete a resource check box.

4. Click Delete to delete the selected resources in bulk.

View, Update, or Export Resources
The administrator can perform the following set of actions for each resource; see Figure 6-9.

• View Resources

• Update Resource Properties 

• Export Resource Files

Figure 6-9 Managed Equipment Actions
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View Resources
The View action displays the following details of a specific resource:

• Resource Properties

• Availability

• Interface Definitions

• Power Supply Definitions

• Console Definitions

• File System Definitions

• Inventory Parameters

To view details of a particular Resource, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. Identify the resource to view, click the Select Action drop-down list and select View. 

The View Details page displays; see Figure 6-10.
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Figure 6-10 View Details

Update Resource Properties
You update the properties of a managed resource by editing its resource instance file. To update a resource 
instance file, you must first export it (see the “Export Resource Files” section on page 6-11) from the Active 
System Manager, make your changes in your XML editor, and then re-import the file to the Active System 
Manager application using the Update feature.

To update resource inventory, perform the following steps: 

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. Identify the resource to update, click the Select Action drop-down list, and select Update. 

The Update Resource Inventory page displays; see Figure 6-11.
6-10 Active System Manager Web Interface User Guide, Release 7.0



Resources > Managed
Figure 6-11 Update Resource Type

3. Click Choose File > Update.

Export Resource Files
The Export feature allows you to update resource instance files. To export a file, perform the following 
steps:

1. On the Active System Manager menu bar, click Resources > Managed to display the list of managed 
equipment currently available in the inventory; see Figure 6-1 on page 6-2.

2. Identify the resource to update, click the Select Action drop-down list, and select Export. 

3. Optional. Click Open With to open file for updates or click Save File to save file for updating.

4. In the Windows Save As page, specify a location for the file, and click Save.

5. Open the file in your preferred XML editor, edit the information, and save your file. 
Note The name and other attributes of this piece of equipment are specified in the XML 

statements in the file, and are independent of the filename. 
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Resources > Control

Control equipment consists of resources that are not visible to the Active System Manager scheduler and 
are used to manage resources in the environment. This includes resources such as compound matrix 
switches, matrix switches, power controllers, and terminal servers.

To open Control sub-menu, on the Active System Manager menu bar, click Resources > Control; see 
Figure 6-12.

Figure 6-12 Control Equipment

As shown in Figure 6-12, the following operations can be performed on Control Equipment Resource type:

• Creating Control Equipment

• Updating Control Equipment Links

• Filtering Control Equipment

• Navigating Control Equipment

• Sorting Control Equipment

• Deleting Batch Operations

• View, Update, or Export Control Equipment

There are seven types of control equipment. All functions are performed in the same way for each of the 
types of equipment. To perform any action on control equipment, first select the sub-sub-menu for the type 
of resource (matrix switch, patch panels, terminal server, power controller, TFTP server, or hub) and 
continue with the desired function.

Note The best way to create, add, or modify all resource types is with the Inventory perspective. 
Also, the Inventory perspective can specify links between control and managed equipment 
and create a DISLINK file.
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Control equipment used in the Active System Manager-enabled environment includes:

• Compound matrix switches

• Matrix switches

• Patch panels

• Terminal servers

• Power controllers

• TFTP servers

• Hubs

Note You can only interact with control resources indirectly.

Creating Control Equipment
The procedure for adding new control equipment to the Active System Manager application is quite similar 
to the procedure for adding managed equipment. This procedure is used for all types of control equipment.

To add new control equipment, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-13.

Figure 6-13 Matrix Switches

2. Click any of the other control equipment menus to manage the equipment. By default, Matrix Switches 
is selected.

3. Click New to add Control Equipment to display the Import Resource Inventory page; see Figure 6-14.
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Figure 6-14 Matrix Switch Resource Inventory Page

4. In the Choose Resource Inventory File section, click Choose File to select a valid resource type file 
from your computer. 

This file will be imported into your environment as a new resource.

5. In the Domain section, click the Choose Domain drop-down list and select a domain (central or 
remote) to associate with the resource.

6. Click Import. 

When the resource type is successfully integrated, the updated resource types displays. You may need 
to click to an earlier or later page in the list to find the new type you have imported. 

Note The first resource type you import for a specific type of equipment automatically becomes 
active.

The Active System Manager performs a “sanity check” to ensure that for the selected resource type, the 
DIS file is compatible with the current resource type. When the resource is successfully created, the 
Control Equipment list displays and it includes your new equipment.
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Updating Control Equipment Links
To add or remove links in your environment, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12.

2. Click Update Links to display the Import Links Definition page; see Figure 6-15.

Figure 6-15 Update Links 

3. Connect or disconnect the links listed in your DISLINK file:

• Click the Connect Links radio button to add the links.

• Click the Disconnect Links radio button to remove the links from the database.

4. Depending on your browser, use the Browse feature (or click Choose File) to navigate to the DISLINK 
file. 

5. Click Import. 

When the links are successfully updated, you are returned to the Control Equipment list.

Note There is never a problem with conflicting links. Any time a different connection is specified 
for an interface with an existing link, the new connection overrides it.
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Filtering Control Equipment
To filter search results for Control Equipment, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12.

2. Click Custom Filtering. 

The Custom Filtering page displays; see Figure 6-16.

Figure 6-16 Custom Filtering

3. Click the Manufacturer, Display Name, and Model drop-down lists, as appropriate, and apply 
contains or is filter.

4. Click the State drop-down list and select APPLICABLE, ACTIVE, FUTURE, or OBSOLET.

5. Click Apply Filter to display search results after filtration.

The Filter Off button displays the status of filter as On or Off.

Navigating Control Equipment
To navigate Control Equipment result pages, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12.

2. Click the navigation panel to select number of records to be displayed per page; see Figure 6-17 as an 
example.

Figure 6-17 Navigation Panel

3. Click the forward or backward arrow to navigate to pages sequentially, or click Page to display a 
drop-down a list of all pages, or click the page number to navigate to directly.
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Sorting Control Equipment
To sort Control Equipment search results, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12.

2. Click any arrow displayed next to a heading row to sort results; see Figure 6-18 as an example.

Figure 6-18 Sort Heading Row

Deleting Batch Operations
To delete one or more resources in batches/bulk, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12.

2. In the Batch column, select one or more resources to delete and click Delete; see Figure 6-19.

Figure 6-19 Deleting Batch Operations

The Delete page displays; see Figure 6-19.

3. If required, click the Don't show me this prompt the next time I delete a resource check box.

4. Click Delete to delete the selected resources in bulk.
Resources 6-17



Resources > Control
View, Update, or Export Control Equipment
The administrator can perform the following set of actions on each resource; see Figure 6-20:

• View Resources

• Update Resource Properties 

• Export Resource Files

Figure 6-20 Managed Equipment Actions

View Resources
The View sub-menu displays the following details of a specific resource:

• Resource Properties

• Availability

• Interface Definitions

• Power Supply Definitions

• Console Definitions

• File System Definitions

• Inventory Parameters

To view details of a specific resource, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12.

2. Identify the resource to view, click the Select Action drop-down list, and select View. 

The View Details page displays; see Figure 6-21.
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Figure 6-21 View Details
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Update Resource Properties
You can update the properties of a Controlled resource by editing its resource instance file. To update a 
resource instance file, you must first export it (see the “Export Resource Files” section on page 6-20) from 
Active System Manager, make your changes in your XML editor, and then re-import the file to the Active 
System Manager application using the Update feature.

To update resource inventory, perform the following steps: 

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12. 

2. Identify the resource to update, click the Select Action drop-down list, and select Update. 

The Update Resource Inventory page displays; see Figure 6-22.

Figure 6-22 Update Details

3. Click Choose File > Update.

Export Resource Files
Export feature allows you to update Resource Instance file. To export file, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Control to display the Matrix Switches 
page (the default page that opens); see Figure 6-12 on page 6-12. 

2. Identify the resource to update, click the Select Action drop-down list, and select Export. 

3. Optional. Click Open With to open file for updates or click Save File to save file for updating.

4. In the Windows Save As page, specify a location for the file, and click Save.

5. Open the file in your preferred XML editor, edit the information, and save your file. 
Note The name and other attributes of this piece of equipment are specified in the XML 

statements in the file, and are independent of the filename. 
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Resources > Resource Type

The Resource Type page includes all the resource types that have been integrated into the Active System 
Manager application. When a resource is added to either control equipment or managed equipment, it is 
based on a resource type that has been integrated. Each resource has an availability period that defines when 
the resource is available for use.

A resource type must be integrated in to the Active System Manager application before it is available as a 
basis for adding new managed and control resources to the inventory.

To open the Resource Type page, on the Active System Manager menu bar, click Resources > Resource 
Type; see Figure 6-23.

Figure 6-23 Resource Type
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As shown in Figure 6-23, the following operations can be performed on a resource type:

• Creating a New Resource Type

• Filtering a Resource Type

• Navigating Resource Types

• Sorting Resource Types

• Deleting Batch Operations

• Update or Export Resource Types

Creating a New Resource Type
A new resource and its characteristics are specified by a resource type file. 

To integrate a new resource type, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Resource Type to display all of the 
managed resource types currently integrated in Active System Manager’s inventory display; see 
Figure 6-23 on page 6-21.

The following information is extracted from the resource type file:

• Manufacturer and Model—Information for this resource.

• Import Date—Date the resource was imported.

2. Click New to integrate a new resource type to display the Import Resource Type page; see Figure 6-24.

Figure 6-24 Import Resource Type

3. In the Choose Resource Type section, click Browse and enter the resource type file to use. The 
resource type should be a .jar (Java archive) file that includes the XML description of the resource, plus 
the graphic file of the resource type’s icon that is referred to in the XML. 
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4. In the Release Notes field, enter a description for the resource type to update. The Active System 
Manager automatically assigns it a version number, and keeps track of the date and time that the file 
was imported.

5. Click Import. 

When the resource type is successfully integrated, the updated resource type listing page displays. You 
may need to click to an earlier or later page in the list to find the new type you have imported. 

Filtering a Resource Type
To filter search results for Resource Type, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Resource Type to display all of the 
managed resource types currently integrated in Active System Manager’s inventory display; see 
Figure 6-23 on page 6-21.

2. Click Custom Filtering. The Custom Filtering page displays; see Figure 6-25.

Figure 6-25 Custom Filtering

3. Click the Manufacturer, Display Name, and Model drop-down lists, as appropriate, and apply 
contains or is filter.

4. Click the Role drop-down list and select one of the following roles: 

• Matrix Switch

• Managed Resource

• Ethernet Hub

• Power Controller

• Terminal Server

• TFTP Server

• Patch Panel
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5. Click Apply Filter to display search results after filtration.

The Filter Off button displays the status of filter as On or Off.

Navigating Resource Types
To navigate Resource Type result pages, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Resource Type to display all of the 
managed resource types currently integrated in Active System Manager’s inventory display; see 
Figure 6-23 on page 6-21. 

2. Click the navigation panel to select number of records to be displayed per page; see Figure 6-26 as an 
example.

Figure 6-26 Navigation Panel

3. Click the forward or backward arrow to navigate to pages sequentially, or click Page to display a 
drop-down a list of all pages. Click the page number to navigate to directly.

Sorting Resource Types
To sort Resource Type search results, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Resource Type to display all of the 
managed resource types currently integrated in Active System Manager’s inventory display; see 
Figure 6-23 on page 6-21. 

2. Click any arrow displayed next to a heading row to sort results; see Figure 6-27.

Figure 6-27 Sort Header

Deleting Batch Operations
To delete more than one Resource Types in batches/bulk, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Resource Type to display all of the 
managed resource types currently integrated in Active System Manager’s inventory display; see 
Figure 6-23 on page 6-21.

2. In the Batch column, select one or more resources to delete, and click Delete; see Figure 6-28.
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Figure 6-28 Deleting Batch Operations

The Delete Resource Type page displays; see Figure 6-29.

Figure 6-29 Deleting Resource Types

3. If required, click the Don't show me this prompt the next time I delete a resource check box.

4. Click Delete to delete the selected resources in bulk.

Update or Export Resource Types
The administrator can perform the following set of actions on each resource type:

• Update Resource Types 

• Export Resource Types

Update Resource Types
You update the properties of a resource type by editing its resource type file. To update a resource type file, 
you must first export it from Active System Manager (if you do not already have access to a current copy 
of the resource type file), make your changes in an XML editor, and then re-import the file to the Active 
System Manager application using the Update feature.
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To update a resource type, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Resource Type to display all of the 
managed resource types currently integrated in Active System Manager’s inventory display; see 
Figure 6-23 on page 6-21.

2. Identify the resource to update, click the Select Action drop-down list, and select Update.

Figure 6-30 Updating a Resource

The Update Resource Type page displays; see Figure 6-31.

Figure 6-31 Updating Resource Type

3. In the Choose Resource Type section, click Browse and enter the resource type file to use. The 
resource type should be a .jar (Java archive) file that includes the XML description of the resource, plus 
the graphic file of the resource type’s icon that is referred to in the XML. 

4. In the Release Notes field, enter a description for the resource type to update. The Active System 
Manager automatically assigns it a version number, and keeps track of the date and time that the file 
was imported.
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5. Click Update. 

When the resource type is successfully integrated, the updated resource type listing page displays. You 
may need to click to an earlier or later page in the list to find the new type you have imported. 

Note The first resource type you import for a specific type of equipment automatically becomes 
active.

Export Resource Types
To export a resource type, perform the following steps:

1. On the Active System Manager menu bar, click Resources > Resource Type to display all of the 
managed resource types currently integrated in Active System Manager’s inventory display; see 
Figure 6-23 on page 6-21.

2. Identify the resource to update, click the Select Action drop-down list, and select Export. The Export 
page displays; see Figure 6-32.

Figure 6-32 Exporting Resource Types

3. Depending on your browser, you are prompted to Save File or Cancel the file. 

4. Click Save. 

A file (.jar extension) is saved to your desktop. This file is a bundle of two files in a zipped, compressed 
format: 1) an XML file, which is the resource type definition file and 2) a picture file used for the Active 
System Manager application. For more information, see the Active System Manager User Guide.
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C h a p t e r  7
Reports
The Active System Manager™ software has several built-in reports for tracking the usage of your 
environment’s inventory. They are usually displayed in your default web browser and can be printed or 
exported to PDF.

You can also use the Active System Manager software to create a wide array of custom reports. For 
additional information on creating custom reports, refer to the available BIRT documentation.
Note For all reports, you can print the output from your browser. Use the Export information in PDF 

format or the Export information in CSV format link to create a PDF file and display it in your 
browser or create a CSV file. The PDF file can be printed or saved from the browser.

Figure 7-1 displays reports accessible to the administrator and Figure 7-2 displays reports accessible to the 
non-administrator Users:
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Figure 7-1 Administrator Reports
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Figure 7-2 Non-Administrator User Reports

Table 7-1 displays the list of reports available to the administrator and non-administrator user:

Table 7-1 List of Administrator and Non-Administrator User Reports

Reports Administrator Non-Administrator User

Custom Reports X X

Control Equipment Summary Report X X

Detailed Session Report X

Inventory Link Detail Report X X

Managed Equipment Summary Report X X

Managed Equipment Detail Report X

Template Utilization Report X

User Management Report X
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Custom Reports

The Active System Manager server comes deployed with BIRT reporting services. For more information, 
see the BIRT documentation. Administrators have the ability to deploy BIRT reports and make them 
available to their end users. Those reports are accessible using the following procedure. 

To run a custom report, on the Active System Manager menu bar, click Reports > Custom Reports. 

The web portal report displays with a list of deployed reports; see Figure 7-3.

Figure 7-3 Custom Report Example

Control Equipment Summary Report

The Active System Manager software provides two types of inventory equipment summaries: one for 
managed equipment and one for control equipment. The Control Equipment Summary report displays 
summary information on the control equipment in inventory on the current server. This report lists each 
item of your control equipment, grouped by category (matrix switch, Trivial File Transfer Protocol [TFTP] 
server, and so on). Any category of equipment that has no resources in it is skipped. For information 
regarding the managed equipment report, see “Managed Equipment Summary Report” section on page 7-8 
and “Managed Equipment Detail Report” section on page 7-9.

To run a Control Equipment Summary report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Control Equipment Summary Report.

The Control Equipment Summary Report for your environment displays in your web browser; see 
Figure 7-4.
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Figure 7-4 Control Equipment Summary Report

This report lists each item of your control equipment, grouped by category (matrix switch, TFTP server, 
etc.). Any category of equipment that has no resources in it is skipped.

Inventory Link Detail Report

The Inventory Link Detail report lists each of the links to your equipment, by resource. You can filter the 
resources used for creating the report in the dialog box provided by your web browser.

To run an Inventory Link Detail report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Inventory Link Detail Report. 

The Inventory Link Detail report filter options dialog box displays in your default web browser; see 
Figure 7-5.
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Figure 7-5 Inventory Link Detail Report

2. Modify the report filter options, as appropriate, and click Create.

Figure 7-6 displays an example of the report output.
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Figure 7-6 Inventory Link Detail Report Output Example
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Managed Equipment Summary Report

The Managed Equipment Summary report displays summary information for the managed equipment in 
inventory. For each item of your managed equipment, it displays its name, manufacturer, model, asset tag, 
version, and description. This report lists the number of entries and those entries are alphabetically sorted 
by Manufacturer and Model. 

To run a Managed Equipment Summary report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Managed Equipment Summary Report 
to display the Managed Equipment Summary report filter options dialog box; see Figure 7-7.

Figure 7-7 Managed Equipment Summary Report—Filter Options

2. Modify the report filter options, as appropriate, and click Create.

Figure 7-8 displays an example of the report output.
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Figure 7-8 Managed Equipment Summary Report—Example 

Managed Equipment Detail Report

The Managed Equipment Detail report lists the ports on each resource, what card they are located on, and 
relationships that apply to them. Use this report to help you manage your environment physically and as a 
network. In particular, this report provides the following information:

• What cards are present on a resource?

• What the location of each card is?

• What ports are present?

• Which ports are on which cards?

• What is the total number of ports for each interface type?

• What is the total number of ports for each card type?
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To run a Managed Equipment Detail report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Managed Equipment Detail Report to 
display the Managed Equipment Detail report—filter options; see Figure 7-9.

Figure 7-9 Managed Equipment Detail Report—Filter Options

2. Select one of the following Filter Options:

• All Resources—Displays information for all managed resources in your inventory. 

• Power Management—Includes all equipment associated with the power management feature.

• Resource Types—Click this option and select one or more resource types. 
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• Resource Instances—Click this option and select one or more resources to display.

• Port Types—Click this option and select one or more port types. 

3. Optional. Enter a comment to appear at the beginning of your report. 

4. Click Create to proceed. 

The report can take a few minutes to generate; see Figure 7-10 for the report that displays.

Figure 7-10 Managed Equipment Detail Report Output Example

The groups are separated from each other by a white space. For each port, the port location is displayed, 
as well as the type of card that it is on and the location of the card.

There is also a summary report at the bottom that displays the total count of each interface type, and the 
total count of each card type for which a name has been entered; see Figure 7-11.
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User Management Report
Figure 7-11 Summary Report

User Management Report

There are two types of security management reports available:

• The User report lists all the administrators in the first section, and then all the (non-administrator) users 
in the next section. Within each section, entries are listed alphabetically by last name, then first name.

• The Group Definition report lists all the groups that have been defined in the Active System Manager 
software. For each group, every member is listed, as well as whether the member is an administrator or 
user.

To run a User Management report, on the Active System Manager menu bar, click Reports > User 
Management Report. 

The User Management report displays in a new window, in your default web browser; see Figure 7-12. This 
can take a few minutes. You can return to the Active System Manager software while the report is being 
generated:
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Figure 7-12 User Management Report Example

5. Click Run Report to generate the output; see Figure 7-13.
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Figure 7-13 User Management Report Output

Detailed Session Report

The Detailed Session report lists the sessions associated with the environment. It includes interactive 
features such as, on rendered pie chart, the user can click an individual segment to retrieve its corresponding 
data only.
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To run a Session report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Detailed Session Report. 

The Sessions Filter Options display; see Figure 7-14.

Figure 7-14 Detailed Session Report 

This filter works in the standard way for the Active System Manager software. 

2. If no criteria is entered, then all sessions are included in the report.

You can perform an advanced filter search based on the parameters:

• Owner

• Template Name

• Session Name

• Status—Select one or more of the status values from the list (All, Active, Canceled). For example, 
you can choose to see only sessions whose status is Running or Setting Up. You can press 
Ctrl+click to select additional entries from the list. Press Shift+click to select a range of entries. If 
you leave this field blank, then the field is not used as a selection criterion (that is, any value is 
acceptable).
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• Start Date—Select a start date by clicking on the calendar. Select “>” from the box at the beginning 
of the line to select sessions that started after the specified date and time, or “<” to select earlier 
dates.

• End Date—Select an end date by clicking on the calendar. Select “>” from the box at the beginning 
of the line to select sessions that ended after the specified date and time, or “<” for earlier dates.

• Click the Show only my sessions check box for those sessions to display.

3. Click Create to display the Administrator Session Report for your environment; see Figure 7-15.

Figure 7-15 Detailed Session Report Output Example

The Detailed Session report displays in a new window, in your default web browser; see Figure 7-15. This 
can take a few minutes. 
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Template Utilization Report

The Template Utilization report displays details of top topologies used by selected users.

To run a Template Utilization report, perform the following steps:

1. On the Active System Manager menu bar, click Reports > Template Utilization Report; see 
Figure 7-16.

Figure 7-16 Template Utilization Report

2. Select the required information from the following parameters:

• Specify Date Range—Allows you to select a period of time or specific start and end times.

• Period—Allows you to set the Utilization report on the prior week, or the last 30, 60, or 90 days.

• Specific Time—Allows you to specify a start and end time to define the time frame the report 
covers. 

• Filter Options—Allows you to select the resources the report is based upon:
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• Security Store—A Active System Manager repository of secured store credentials (users and 
groups). The Active System Manager software supports a local and remote security store (via 
Active Directory or LDAP for example). 

• Groups—Lists all the groups that have been defined in the Active System Manager software. 
For each group, every member is listed, as well as whether the member is an administrator or 
user.

• Users—Lists all the administrators in the first section, and then all the (non-administrator) users 
in the next section. Within each section, entries are listed alphabetically by last name, then first 
name. You can select a user and click Remove or Edit at any time to remove or edit the 
participants.

• Specify Top Template Count—Displays only the top 10 most-used topologies in the report.

3. Click Run Report. 

The Template Utilization report displays, see Figure 7-17:

Figure 7-17 Template Utilization Report Output Example

The Template Utilization Report displays in a new window, in your default web browser; see Figure 7-17. 
This can take a few minutes. 
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Printing Reports

The Active System Manager software reporting feature is designed to print out all information in a given 
category. For best results, use the Landscape mode in your browser’s print settings.

Printing Reports from an HTML Browser
To print a report from your HTML browser, click File > Print. This menu prints all the information in a 
given category—not just the information displaying on the page.

Printing Reports from a Web Browser
To print reports from your web browser, perform the following steps:

1. Click File > Page Setup.

2. Set the orientation to Landscape mode.

3. Verify that the Print background colors and images option is enabled.

4. Exit the Page Setup dialog box.

5. Click File > Print. Alternatively, you can use the link at the upper right of the report to export the report 
as a PDF.
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Security
The Active System Manager software supports two different roles: users and administrators. Roles are 
associated to a user profile. Each role comes with a specific set of built-in permissions. Those permissions 
are not configurable contrary to those that you can set in the user profile. For more information about roles, 
see the Active System Manager User Guide.

Figure 8-1 displays the Security page (Administrator Role). Figure 8-2 displays the Security page (User 
Role).

Figure 8-1 Security
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Figure 8-2 Security > User Role

The Active System Manager software lets you set permissions to access a number of privileges, such as 
making sessions and importing and exporting templates from the library. The types of entities that have 
permissions assigned and that can be managed using the Security sub-menu include:

• Users—Users, at a generic level, can perform core Active System Manager functions such as making 
sessions and working with templates, as described in the Active System Manager User Guide. 

• Groups—Groups are used as handy time-savers. Groups can be composed of administrators, users, and 
even other groups. You can assign any number of users to a group, and then set the permissions for the 
group. All of the users have those permissions, without having to set them for each user individually.

Working with Users

Initially, Active System Manager comes with only one pre-defined administrator username (admin) and no 
users. The following sections describe the Active System Manager user (non-administrator) functionality:

• Defining User Roles

• Filtering Users

• Creating a New User

• Navigating Users

• Sorting Users

• Cloning Users

• Editing Administrator Profiles

• Deleting Users or User IDs
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Defining User Roles

Note A user can have administrator privileges based on its profile role. 

Note By default, the admin account is defined as a superuser account. Its profile information 
cannot be changed and it is read-only. 

Table 8-1 defines the administrator’s and user’s roles.

Table 8-1 Administrator and User Roles 

Functionality Administrator Role User Role

Inventory • Full access to inventory management 
(types, instances, connectivity/links)

• Manage dependencies
• Manage interface type and compatibility 

matrix

• Read-only view of the entire inventory
• Read-only view of interface types

Discovery Access to Discovery functions None

Security • Manage all users, includes user profile, 
memberships, and permissions

• Manage all groups, includes group 
profile, memberships, and permissions

Update its user profile only

Authoring • Create, modify, and share all templates
• Open and Save As All templates
• Delete all templates
• Import all templates
• Export all templates

• Create, modify, and share templates
• Update owned templates
• Open all templates
• Delete owned templates
• Import/export templates

Scheduling/Sessions • Manage owned sessions
• Access to all sessions 
• Purge sessions

• Manage owned sessions
• Create, update, delete owned sessions

Session Notifications • Define system-wide notifications
• Define owned session notifications
• Define specific session notifications

• Delete user-defined notifications
• Define owned session notifications
• Define specific session notifications

Archiving • Define system-wide archiving rules
• Restore owned templates and sessions
• Restore any session

Restore owned templates and sessions

Reporting • Access to all reports
• Execute custom reports

• Access to user-based reports only
• Execute custom reports

Session • Access to all sessions
• Manage console access

Access and manage only owned 
sessions, or one user is a participant

Testing List and execute associated test cases List and execute test cases within owned 
or participant sessions

Note Before using the Active System Manager product, the administrator, user, and group contact 
information and access permissions must be stored as profiles in the Active System 
Manager database.
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The administrator has more access to a larger set of functionality within the Active System Manager 
system. The role of the Active System Manager administrator includes all of the capabilities of the Active 
System Manager user, because the administrator may also be a user, and can also extend them by including 
additional responsibilities for inventory management, template management and sessions, and report 
management.

For example, the Active System Manager administrator can perform the following functions:

• Create, modify, delete, and save templates of all users

• Configure system-wide session notifications and reminders

• Cancel, modify, delete, and save (snapshot) sessions

• Start and stop ASAP Rescheduling and other scheduling properties

Table 8-2 lists and describes the Active System Manager administrator tasks; a cross-reference for more 
information is provided in the last column. For more information about these tasks, see the Active System 
Manager User Guide and the Active System Manager Server Installation Guide.

Table 8-2 Active System Manager Administrator Tasks 

Task Description

Installing, upgrading, and 
uninstalling the Active System 
Manager software

Typically, the Active System Manager administrator is responsible for installing, upgrading, and 
uninstalling the Active System Manager client and server software. The administrator owns the 
<Active System Manager_home> directory, where the Active System Manager server 
software is installed. The Active System Manager administrator makes the Active System Manager 
server available to all users. The Active System Manager client software is designed to be installed 
by all Active System Manager users on their client hardware platforms. 

Consulting the Active System 
Manager user community

Configuring the Active System Manager software can be a complex and time-consuming task, 
depending on the level of customization required in your organization. Further, because the Active 
System Manager software addresses the needs of many different types of users—from individual 
environment users to department managers—there can be several different interpretations of how 
best to configure the environment, depending on the tasks the user needs to perform and the 
user’s role in the organization. 

Consulting the Active System 
Manager user community

Before modifying the Active System Manager environment, the Active System Manager 
administrator should consult with environment planners, environment developers, QA managers, 
and other key members of the testing team, to determine what site-specific changes and 
customizations are needed. In general, it is best to install the product, then implement, and test 
system-wide changes before deploying the product for general use.

Integrating the Active System 
Manager software with other 
products

The Active System Manager administrator is responsible for installing integrations with third-party 
products. The Active System Manager software integrates with configuration management tools 
(ClearCase and Concurrent Versions Systems [CVS]).

Managing inventory The Active System Manager administrator is responsible for building and managing the 
environment’s resource inventory, which includes the various general resource types within your 
environment, as well as specific instances that require a particular configuration for a particular 
piece of network equipment. 
The administrator uses the Active System Manager portal to define and catalog the specific types 
of equipment interfaces, and each general type of network hardware in the environment. 

Managing Active System Manager 
templates and sessions

The administrator can use the Active System Manager portal and all of the functions to create, 
update, save, validate, schedule, and delete templates. In addition, the administrator can cancel or 
edit present or future sessions of other users, or delete past sessions. 

Creating administrator or custom 
reports

The Active System Manager software includes a set of pre-defined, web-based support that has 
the ability to create administrator-specific reports. 

Managing security privileges The Active System Manager administrator has many built-in permissions, separate from the user 
role. 
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Viewing User and Administrator List
To view a list of users and administrators, perform the following steps:

1. On the Active System Manager menu bar, click Security > Users to display the current list of users; 
see Figure 8-2 on page 8-2 as an example.

2. Toggle between users and groups using the toggle Admin | User button.

Filtering Users
To filter search results for User list, perform the following steps:

1. On the Active System Manager menu bar, click Security > Users > Custom Filtering. The Custom 
Filtering page displays; see Figure 8-3.

Figure 8-3 Custom Filtering

2. Click the User Name, Email, and First Name drop-down lists, respectively, apply the Contains or Is 
filtering, and enter a name for each parameter.

3. Click Add More Filters to add the Last Name and Security filter, if required.

4. Click Apply Filter to display search results after filtration.

The Filter Off button displays the status of filter as On or Off.
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Creating a New User
To create a new user profile, you must be logged in as an administrator before perform the following steps:

1. On the Active System Manager menu bar, click Security > Users to display the current list of users; 
see Figure 8-2 on page 8-2.

2. Click New User to display the Create New User page; see Figure 8-4.

Figure 8-4 Create a New User
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3. In the Contact Information section, enter the User Name, Email Address, First Name, Last Name, 
Company (optional), and Department (optional) fields.

4. In the Security section, define the following mandatory fields:

• New Password—Enter between 6 and 25 alphanumeric characters, including spaces. For security 
reasons, it is important to change your admin password the first time you log on to the Active 
System Manager application.

• Confirm Password—Re-enter the new password for verification purposes.

5. In the User Role section, select your user role as User and Admin.

6. In the Preferences section, select the desired Time Zone to use for the sessions that you execute. 

The scheduler processes all requests with respect to Greenwich Mean Time (GMT). Your entry in this 
field determines how the time zone for all activity calculates and displays. For example, assume that the 
Active System Manager server is located on the West coast (Pacific Standard Time [PST]). A session 
is scheduled to begin at 10:00 a.m. PST. If a user on the East coast has a time zone display set for Eastern 
Standard Time (EST), the session appears to start at 1:00 p.m. EST.

The default time zone for all sessions is based upon this optional entry. All sessions are scheduled with 
respect to the current time in the zone selected.

7. In the User Priority section, select the user priority (the default user priority is 3).

8. In the Session Controls section, configure the following parameters: 

a. In the Maximum Session Duration section, perform the following steps:

• Click the Specify Maximum Session Duration Constraint check box to enforce the maximum 
duration at the time of scheduling. This is defined by your administrator.

• Select the number of Days, Hours, and Minutes for this user.

b. In the Maximum Active Sessions section, perform the following steps:

• Click the Specify Maximum Active Session Constraint check box to enforce the maximum 
sessions limit at scheduling time. This is defined by your administrator.

• Enter the number of maximum number of active sessions.

9. Click Save to save the new user profile. 

If the user belongs to a group and uses the group’s permissions, then you can skip setting user-level 
permissions. 

Note You should create both a profile and a set of permissions for a new user. 

You can also create a new user by cloning a similar user that already exists. This saves time by copying 
the new user’s group memberships and permissions from an existing user. For more information, see 
the “Cloning Users” section on page 8-8.
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Navigating Users
To navigate a list of user pages, perform the following steps:

1. On the Active System Manager menu bar, click Security > Users to display the current list of users; 
see Figure 8-2 on page 8-2. 

2. Click the navigation panel to select number of user records to be displayed per page; see Figure 8-5.

Figure 8-5 Navigation Panel

3. Click the forward or backward arrow to navigate to pages sequentially, or click on Page to display list 
of navigational pages.

Sorting Users
To sort the user list, perform the following steps:

1. On the Active System Manager menu bar, click Security > Users to display the current list of users; 
see Figure 8-2 on page 8-2. 

2. Click any arrow displayed beside each column header to sort results in ascending or descending order; 
see Figure 8-6.

Figure 8-6 Sort Header

Cloning Users
Some administrators use a time-saving method for creating users called cloning. Instead of setting each new 
user’s permissions by hand, the administrator creates a template user ahead of time. This template user 
already has the basic groups and permissions that are common to all users. When a new user has to be 
created, the admin copies, or “clones” the template user and makes any individual tweaks that might be 
needed.

To clone a user, perform the following steps:

1. On the Active System Manager menu bar, click Security > Users to display the current list of users; 
see Figure 8-2 on page 8-2.

2. Select the entry for the user to use as a starting point.

3. Select a user, in the Action column, click the Select Action drop-down list, and select Clone.
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Figure 8-7 User Related Actions

4. Click Clone to display the new Clone User page, which is similar to that of the “Create a New User” 
section on page 8-6.

The Email, Company, Department, Group memberships, Role, and Time Zone, and Maximum 
Session Duration fields are already filled in as for the original user. You can tweak these fields. as 
necessary.

5. Configure the remaining parameters for the new user, and click Save.

The new user is cloned with the same permissions as the original user. 

Editing Administrator Profiles
To edit an administrator user profile, perform the following steps:

1. On the Active System Manager menu bar, click Security > Users to display the current list of users; 
see Figure 8-2 on page 8-2.

2. Select the entry for the administrator user to edit or modify.

3. Select a user, in the Action column, click the Select Action drop-down list, and select Edit; see 
Figure 8-8.
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Figure 8-8 Editing Administrator Profile Settings

In Figure 8-8, you can edit the user profile, as well as permissions by clicking Profile or Permissions. 
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Modifying the Profile 
When you click Profile, Figure 8-8 displays. By default, the existing, assigned username displays, as well 
as a list of member groups for that user.

You can modify the following fields:

• Required. First Name and Last Name—Use admin for both the first and last name.

• Required. Email—The email address that receives all alerts and administrator-related mail.

• Optional. Company—Your company name.

• Optional. Department—Your department. 

• Required. Password—This can be up to 25 alphanumeric characters, including spaces. For security 
reasons, it is important to change your admin password the first time you log on to the Active System 
Manager application.

• Optional. Time Zone Display—The scheduler processes all requests with respect to GMT. Your entry 
in this field determines how the time zone for all activity calculates and displays. For example, assume 
that the Active System Manager server is located on the West coast (Pacific time). A session is 
scheduled to begin at 10:00 a.m. Pacific time. If a user on the East coast has a time zone display set for 
EST, the session appears to start at 1:00 p.m. EST.

• Optional. Security Repository—Location where this information is to be stored.

• Click Save.

Setting Permissions
You can set permissions for a number of very specific types of access. For each type of access, you can 
permit or deny access. When you initially go to the permissions page for a new entry, no permissions are 
specified until you permit or deny each function. There are three values:

• Permit—Allow this type of access

• Deny—Do not allow this type of access

Access is not allowed, unless permission is specified elsewhere, as discussed below.

This means that new users cannot even log in, until you grant them this permission. The predefined admin 
user has all Active System Manager permissions granted, so that you are permitted to perform all necessary 
tasks as soon as the software is installed.

Permissions may be assigned to a new user or group, and can be modified later. 

If you do not set any permissions for a user and you have assigned the user to a group, then that group’s 
permissions are inherited. If a user that has no permissions assigned is not part of a group, then that user is 
not able to use Active System Manager, because even a login is denied. 

For another situation; for example, setting many of the permissions for a user, but leaving some unspecified. 
In this case, the group’s settings are used for those permissions that were unspecified for the user. If those 
permissions are unspecified for the group as well, or the user doesn’t belong to a group, then those types of 
access are denied.

For example, if a particular permission is unspecified for a user, and the user is a member of several groups 
with conflicting permissions. In this case, if any of the groups is denied that permission, the user is denied.
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Note If the permission has been specified for the user, then that overrides the group permission.

When you click Permissions, Figure 8-9 displays.

Figure 8-9 Permissions

Table 8-3 lists and describes the individual permission types of access that you can control. You can also 
manage these permissions from the Active System Manager portal in the user profile.
Table 8-3 Permission Types 

Permission Type Description

Active System Manager

Logging In and Out Allows the user to access the Active System Manager server from the Active System 
Manager portal or the API.

Sessions

Make sessions Allows sessions to be created based on available resources in the environment.

Archive
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By default, the DENY ALL radio button is selected. 

4. Click PERMIT ALL for each of the types of access that are to be allowed; click DENY ALL if the 
access is not to be allowed. 

Note The PERMIT ALL and DENY ALL buttons allow you to set all of the permissions the 
same way quickly. Then you can change individual permissions. 

5. Optional. Click Restore to restore the permissions to the values they had when you first displayed them.

6. Click Save and return to the User List.

Deleting Users or User IDs
To delete a user or user ID, perform the following steps:

1. On the Active System Manager menu bar, click Security > Users to display the current list of users; 
see Figure 8-2 on page 8-2. If necessary, click Administrator or User to toggle between the list of 
administrators and users.

2. Select the entry for the administrator user to delete.

3. Select a user, in the Action column, click the Select Action drop-down list, and select Delete to display 
Figure 8-10.

Import Template Allows importing a template from the web application, client, and API.

Export Template Allows exporting a template from the web application, client, and API.

Provisioning

Create Repository 
Element

Available only on the client and API. Allows the creation of repository elements.

Modify Repository 
Element

Available only on the client and API. Allows the modification of repository elements.

Delete Repository 
Element

Available only on the client and API. Allows the deletion of repository elements.

Import Resource Adapter 
Package

Available only on the client and API. Allows the import of Resource Adapters (.rap) 
files.

Delete Resource Adapter 
Package

Available only on the client and API. Allows the deletion of Resource Adapters.

Table 8-3 Permission Types (continued)

Permission Type Description
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Figure 8-10 Deleting Users

4. Click the Don’t Show Me this prompt the next time I delete a user check box to skip this 
confirmation page in the future.

5. Click Submit to delete the selected user.

Working with Groups

Groups are made up of users and administrators. The group has its own set of permissions that are applied 
to its members, as described at the beginning of this chapter.

To work with groups, the following sections describe the Active System Manager group functionality; see 
Figure 8-11. To access the groups, on the Active System Manager menu bar, click Security > Groups to 
display the current list of groups; see Figure 8-11.
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Figure 8-11 Groups 

As shown in Figure 8-11, the Groups-related functionality includes the following:

• Creating a New Group

• Navigating Groups

• Editing Group Profiles

• Editing Group Permissions

• Deleting Groups

Creating a New Group
To create a new group, you add the users and administrators that need to belong to it. You many also add 
other existing groups as members of your group. Then set the permissions for your group. Groups are 
managed in similar ways to users. A Group List displays all existing lists. A group’s name and members 
are described by its profile. Permissions are created or modified by clicking the Edit icon for a group and 
then selecting the Permissions sub-menu. Creating and modifying the profile for a group is different than 
working with a User Profile, and is described in the following procedure.

To create a group, perform the following steps:

1. On the Active System Manager menu bar, click Security > Groups to display the current list of groups; 
see Figure 8-11.

2. Click New Group to display the Create New Group page; see Figure 8-12.
Security 8-15



Working with Groups
Figure 8-12 Create New Group

3. In the Contact Information section, click the Group Name field and enter the name of your new 
group.

4. In the Group Members section, select and organize participants for your new group.

5. In the Group Priority section, select a priority of 1–5.

6. In the Session Controls section, perform the following steps:

a. For Maximum Session Duration, perform the following steps:

• Click the Specify Maximum Session Duration Constraint check box to enforce the maximum 
duration at the time of scheduling. (This is defined by your administrator.)

• Select the number of Days, Hours, and Minutes for this user.
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b. For Maximum Active Sessions section, perform the following steps:

• Click the Specify Maximum Active Session Constraint check box to enforce the maximum 
sessions limit at scheduling time. (This is defined by your administrator.)

• Enter the number of maximum number of active sessions.

7. Click Save to accept and save your selection. 

Navigating Groups
To navigate a list of user pages, perform the following steps:

1. On the Active System Manager menu bar, click Security > Groups to display the current list of groups; 
see Figure 8-11 on page 8-15. 

2. Click the navigation panel to select number of group records to be displayed per page; see Figure 8-13.

Figure 8-13 Navigation Panel

3. Click the forward or backward arrow to navigate to pages sequentially, or click on Page to display list 
of navigational pages.

Editing Group Profiles
To edit group profiles, perform the following steps:

1. On the Active System Manager menu bar, click Security > Groups to display the current list of groups; 
see Figure 8-11 on page 8-15.

2. Select a group, in the Action column, click the Select Action drop-down list, and select Edit to display 
Figure 8-14. By default, the group profile displays.
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Figure 8-14 Editing (Updating) a Group Profile

3. Click Save to save your settings and return to the Group List.
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Editing Group Permissions
To edit group permissions, perform the following steps:

1. On the Active System Manager menu bar, click Security > Groups to display the current list of groups; 
see Figure 8-11 on page 8-15.

2. Select a group, in the Action column, click the Select Action drop-down list, and select Edit to display 
Figure 8-14.

3. Click Permissions.

Figure 8-15 Editing (Updating) a Group Profile

By default, all of the PERMIT ALL/DENY ALL radio buttons are empty, meaning that all access 
permissions are unspecified. 

4. Click PERMIT ALL for each of the types of access that is allowed. Click DENY ALL if the access is 
not allowed.

5. Click Save to save your settings and return to the Group List.
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Deleting Groups
To delete a group, perform the following steps:

1. On the Active System Manager menu bar, click Security > Groups to display the current list of groups; 
see Figure 8-11 on page 8-15.

2. Select a group, in the Action column, click the Select Action drop-down list, and select Delete to 
Figure 8-16.

Figure 8-16 Delete

3. Click the Don’t Show Me this prompt the next time I delete a group check box to skip this 
confirmation page in the future.

4. Click Delete to delete the selected group.
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C h a p t e r  9
Settings
This chapter describes the Settings page, which allows the administrator to set a variety of system settings. 
To access the Settings page, on the Active System Manager menu bar, click Settings. The Settings page 
displays with the Settings sub-menu open, by default; see Figure 9-1. 

Figure 9-1 Settings Main Page (Email Notification, Script Server) 
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Configuring System Settings
The administrator can configure the following settings from the Settings sub-menu:

• Configuring System Settings

• Backing Up and Scheduling the Database

• Viewing License Status

• Viewing and Adding Script Servers

• Managing Properties

Configuring System Settings

The Settings sub-menu allows the administrator to set e-mail notification settings, script server settings, 
and general settings.

To configure system settings, perform the following steps:

1. On the Active System Manager menu bar, click Settings > Settings to display the Setting page; see 
Figure 9-1 on page 9-1.

2. In the Email Notification Settings section, specify your email settings for outbound notifications.

Table 9-1 lists and defines the fields to be set for sending email notifications.

Table 9-1 E-mail Notification Settings Fields 

Fields Description

SMTP Server Host Enter SMTP server host

'From' Field Enter Active System Manager’s support email id; For Example: “Active System 
Manager.Support@galetechnologies.com”

'To' Field Enter recipients email id; For Example: “Active System 
Manager.Feedback@galetechnologies.com”

Email Subject Enter subject of the mail; For Example: “Active System Manager Feedback 
Notification”

 

3. In the Script Sever Settings section, specify your script server settings that will be used by the Active 
System Manager for remote scripts execution

Table 9-2 lists and defines the fields to be set for script server settings.
 

Table 9-2 Script Server Settings Fields 

Fields Description

Host Enter the script server host to be used by the Active System Manager for remote 
script execution.

Username Pre-populated field. Enter the script server username.

Password Pre-populated field. Enter the password.

Remote Script Location Enter the server’s remote script location.

Resource Script Location Enter the server’s resource script location.
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4. In the General Settings section, configure the settings described in Table 9-3.

Table 9-3 General Settings Fields 

Fields Description

Enable preference based graphical editor 
support in the Active System Manager RCP 
client.

Click to enable this check box if the deployment involves large 
templates. If this flag is true, RCP allows preference based 
graphical editor support in template and session.

Maximum resource count Set a maximum number of resources for which graphical editor 
can be opened. This is a performance setting for RCP client 

5. In the Scheduler Options Settings section, specify the scheduler options for the fields described in 
Table 9-4.

Table 9-4 Scheduler Options Settings Fields 

Fields Description

Generate scheduler solution identification logs Specify whether or not to generate logs in lux.log file identifying 
solutions for the given template request.

Use randomness while finding resource Specifies that while finding solution one can introduce the 
randomness within the identified candidates such that in the 
overall Active System Manager system, one set of resource is not 
consumed more than other. Here solution is no longer dependent 
on the sequence of resource in database. But this has an impact 
on the power management solution for VM resource.

Solution of differing resource Specify that while finding multiple solutions for a template 
whether scheduler should give solutions which are differing in 
interfaces or it should differ in allocated resource instances.

6. In the Active System Manage Session Approval Settings section, specify the session approval options 
in Table 9-5.

Table 9-5 Active System Manager Session Approval Settings Fields 

Fields Description

Deploy Active System 
Manager Session Approval

Check to enable all Active System Manager-related fields to enter information.

Session Approval Buffer 
Time (in minutes)

Specify the amount of buffer time, in minutes, to approve the session. The default is 30 
minutes.

7. Click Save.

Reservation Script 
Parameters 

Enter the reservation’s script parameters.

Device Script Parameters Enter the device’s script parameters.

Secure Communication Check for establishing and ensuring securing communication.

Table 9-2 Script Server Settings Fields (continued)

Fields Description
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Backing Up and Scheduling the Database

The Database sub-menu allows the administrator to backup the database and schedule backup operation 
for the database.

To back up and schedule the database, perform the following steps:

1. On the Active System Manager menu bar, click Settings > Database to display the existing database 
listing; see Figure 9-2.

Figure 9-2 Database

As shown in Figure 9-2, the following operations are available on the Database sub-menu:

• Backing Up the Database

• Refreshing the Database

• Scheduling the Database

• Logging Files

• Deleting an Existing Database Record

• Restoring a Database List
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Backing Up the Database
To back up the database, perform the following steps: 

1. On the Active System Manager menu bar, click Settings > Database to display the existing database 
listing; see Figure 9-2 on page 9-4.

2. Click Backup Now to display the database names to back up; see Figure 9-3.

Figure 9-3 Backup Now

Refreshing the Database
To refresh the database, perform the following steps: 

1. On the Active System Manager menu bar, click Sessions > Database to display the existing database 
listing; see Figure 9-2 on page 9-4.

2. Click Refresh; see Figure 9-3 for an example.

Scheduling the Database
The Scheduler operation allows you to schedule the backup operation for the database. 

1. On the Active System Manager menu bar, click Settings > Database to display the existing database 
listing; see Figure 9-2 on page 9-4.

2. Click Scheduler.

The Scheduler page displays; see Figure 9-4.
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Figure 9-4 Schedule Database

Table 9-6 lists and defines the fields to be set for scheduling database backup:

Table 9-6 Schedule Database Backup Fields 

Fields Description

Backup Location Enter the backup location for the specified database.

Enable DB Backup 
schedule

Click the check box to enable the database backup schedule.

 

3. Click Save.

Logging Files
The Log File operation allows you to create a log file of the selected database from the list for future 
reference. 

To create a log file of selected database entry, perform the following steps:

1. On the Active System Manager menu bar, click Settings > Database to display the existing database 
listing; see Figure 9-2 on page 9-4.

2. Select a file, in the Action column, click the --select-- drop-down list, and select Log File. 

3. When prompted, open the file in XML editor or choose your own program to open the selected file.

4. Click Save.

5. Click the Do this automatically for files like this from now on check box, if required

6. Click OK to open or save the log file.
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Deleting an Existing Database Record
1. On the Active System Manager menu bar, click Sessions > Database to display the existing database 

listing; see Figure 9-2 on page 9-4.

2. Select a file, in the Action column, click the --select-- drop-down list, and select Delete. 

Restoring a Database List
1. On the Active System Manager menu bar, click Settings > Database to display the existing database 

listing; see Figure 9-2 on page 9-4.

2. Select a file, in the Action column, click the --select-- drop-down list, and select Restore.
Note The Restore option is available only when the backup operation is successfully completed. 

Viewing License Status

The License sub-menu allows the administrator to view the licensing status. To view licensing status, 
perform the following steps:

1. On the Active System Manager menu bar, click Settings > License to display the current licensing 
information and associated live (current) counters; see Figure 9-5.

Figure 9-5 Current Licensing Status

2. Optional. Click the (counters) icon in Figure 9-5, to refresh the resource count and display the 
currently allocated resources.
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3. Optional. Click Get New License to deploy or install a new product license. 

4. When the next license screen displays (Figure 9-6), send an email (support@dell.com) to the Dell 
Support team to request a product license.

Figure 9-6 Get New License

5. When the Dell Support team responds to your software license request, paste the license file provided 
and click Submit.
9-8 Active System Manager Web Interface User Guide, Release 7.0



Viewing and Adding Script Servers
Viewing and Adding Script Servers

The Script Servers sub-menu allows the administrator add and view the list of added script servers.

To view and add script servers, on the Active System Manager menu bar, click Settings > Script Servers 
to display the list of existing script servers; see Figure 9-7.

Figure 9-7 Script Servers

The following operations are available on the Script Servers sub-menu:

• Creating a New Script Server

• Deleting Script Servers

Creating a New Script Server
To create a new script server, perform the following steps:

1. On the Active System Manager menu bar, click Settings > Script Servers to display the list of existing 
script servers; see Figure 9-7. 

The Add HTTP Script Server dialog box displays; see Figure 9-8.

Figure 9-8 Add HTTP Script Server

Table 9-7 lists and defines the fields to be set for adding a new HTTP Script Server:
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Table 9-7 Fields for Adding HTTP Script Server 

Fields Description

Server Name * Mandatory field. Enter the HTTP script server’s name to be added.

Server IP Address* Mandatory field. Enter the HTTP script’s server IP address.

Server Port * Pre-populated by the default port number.

 

2. Click Save to add new HTTP script server. 

Deleting Script Servers
To delete an existing script server from the list, perform the following steps:

1. On the Active System Manager menu bar, click Settings > Script Servers to display the list of existing 
script servers; see Figure 9-7 on page 9-9.

2. In the Delete column, select a script server to delete and click the Delete icon; see Figure 9-7 on 
page 9-9.

Managing Properties

You can update the properties of the following Active System Manager components by exporting a .csv file 
and updating it. You can then import the updated properties .csv file to update the properties of the 
following components:

• Inventory

• Template

• Session

• Template Link

• Preferences

Note The Import (Refer“Importing Properties” section on page 9-11) and Export 
(Refer“Exporting Properties” section on page 9-12) operation works in a similar manner for 
all mentioned components.

You can perform the following functions to manage Active System Manager properties:

• Viewing Properties

• Importing Properties

• Exporting Properties
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Viewing Properties
To view properties, on the Active System Manager menu bar, click Settings > Properties to display the list 
of existing script servers; see Figure 9-9.

Figure 9-9 Properties

Importing Properties
To import properties, perform the following steps:

1. On the Active System Manager menu bar, click Settings > Properties to display the list of existing 
script servers; see Figure 9-9.

2. Click one of the following tabs: Inventory, Template, Session, Template Link, Preferences, or 
Provisioning.

3. Click Import to display the Import page; see Figure 9-10.
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Figure 9-10 Import Inventory Properties page

4. Click Choose File to browse and select a file (.csv file format only).

5. Click Import to import file.

Exporting Properties
To import properties, perform the following steps:

1. On the Active System Manager menu bar, click Settings > Properties to display the list of existing 
script servers; see Figure 9-9.

2. Click one of the following tabs: Inventory, Template, Session, Template Link, Preferences, or 
Provisioning.

3. Click Export.

A dialog box for the .csv file displays, prompting you to choose how to open the file; see Figure 9-11.

Figure 9-11 Exporting Properties

4. Click the Open File radio button and select Microsoft Office Excel (default) format, or choose your 
own program to open the selected file.
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5. Optional. Click the Save File radio button to specify a preferred location.

6. Optional. Click the Do this automatically for files like this from now on check box.

7. Click OK to open or save the log file.

8. Open the file from and update properties in the .csv file.
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